kernel: kmod-serial-8250: fix linux 5.3 dependencies
authorMathias Kresin <dev@kresin.me>
Mon, 16 Mar 2020 20:16:07 +0000 (21:16 +0100)
committerMathias Kresin <dev@kresin.me>
Mon, 16 Mar 2020 21:28:16 +0000 (22:28 +0100)
Beginning with linux 5.3, kmod-serial-8250 uses functions provided by
serial_mctrl_gpio.ko if GPIO support is enabled.

Signed-off-by: Mathias Kresin <dev@kresin.me>
package/kernel/linux/modules/other.mk

index 147ad99cd19c46889acdf2788bcee7af1afa99aa..f1a70bf069145d1c8ebd85a99eb1b23d3ff51ff8 100644 (file)
@@ -732,7 +732,8 @@ define KernelPackage/serial-8250
   FILES:= \
        $(LINUX_DIR)/drivers/tty/serial/8250/8250.ko \
        $(LINUX_DIR)/drivers/tty/serial/8250/8250_base.ko \
-       $(if $(CONFIG_PCI),$(LINUX_DIR)/drivers/tty/serial/8250/8250_pci.ko)
+       $(if $(CONFIG_PCI),$(LINUX_DIR)/drivers/tty/serial/8250/8250_pci.ko) \
+       $(if $(CONFIG_GPIOLIB),$(LINUX_DIR)/drivers/tty/serial/serial_mctrl_gpio.ko@ge5.3)
   AUTOLOAD:=$(call AutoProbe,8250 8250_base 8250_pci)
 endef