scripts/checkpatch.pl: fix README.md file name after rename
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 2 Aug 2020 13:51:39 +0000 (15:51 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 2 Aug 2020 13:51:39 +0000 (15:51 +0200)
checkpatch.pl uses a list of files to detect the root OpenWrt
directory. This includes README, which has been renamed to
README.md in the previous commit.

Update the file name in checkpatch.pl to prevent errors like the
following when running the script:

   Must be run from the top-level dir. of a OpenWrt tree

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
scripts/checkpatch.pl

index 5224ea49c3b27985c3d15928c2748467dce4fdd4..24793e19d879ef0538b6a040faa849feb40aa42d 100755 (executable)
@@ -391,7 +391,7 @@ sub top_of_openwrt_tree {
        my ($root) = @_;
 
        my @tree_check = (
-               "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README",
+               "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README.md",
                "feeds.conf.default", "include", "package", "rules.mk",
                "scripts", "target", "toolchain", "tools"
        );