kernel/modules: prevent bonding driver to create default bond0 interface
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 8 Sep 2021 12:14:27 +0000 (14:14 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 31 Oct 2021 23:56:51 +0000 (00:56 +0100)
When loading the bonding driver, bonding interface are automatically
created on bonding module load.

> ip a s bond0
> 14: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN
> group default qlen 1000
>    link/ether a6:f2:20:64:c1:b9 brd ff:ff:ff:ff:ff:ff

This is not necessary in openwrt as we do not use this created interface.
The netifd creates a bonding interface based on its network configuration
name and configures this over the netifd bonding proto handler.

In order to keep the overview of the interfaces clear, bonding
interfaces should not be created automatically when loading this module,
because they are not used anyway.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
package/kernel/linux/modules/netsupport.mk

index 62d79db51e1bfb4639950db9655e14b748c7e067..166172dbf36538aacf757d22c7057df8029b7102 100644 (file)
@@ -48,6 +48,7 @@ define KernelPackage/bonding
   KCONFIG:=CONFIG_BONDING
   FILES:=$(LINUX_DIR)/drivers/net/bonding/bonding.ko
   AUTOLOAD:=$(call AutoLoad,40,bonding)
+  MODPARAMS.bonding:=max_bonds=0
 endef
 
 define KernelPackage/bonding/description