build,json: fixup fixup of arch_packages
authorPaul Spooren <mail@aparcar.org>
Thu, 25 Mar 2021 04:54:36 +0000 (18:54 -1000)
committerPaul Spooren <mail@aparcar.org>
Thu, 25 Mar 2021 05:03:24 +0000 (19:03 -1000)
The commit "1bf2b3fe90 build,json: fixup missing arch_packages" fixes
the missing package architecture locally but runs $(TOPDIR)/Makefile
rather than a target specific one. While this works on local builds just
fine, it causes the buildbots to add garbage to the `arch_packages`
variable:

    cd \"/builder/shared-workdir/build\"; git log --format=%h -1
    toolchain > /builder/shared-workdir/build/tmp/.ver_check\ncmp -s
    /builder/shared-workdir/build/tmp/.ver_check
    /builder/shared-workdir/build/staging_dir/toolchain-x86_64_gcc-8.4.0_musl/stamp/.ver_check
    || { \\\n\trm -rf
    /builder/shared-workdir/build/build_dir/target-x86_64_musl
    /builder/shared-workdir/build/staging_dir/target-x86_64_musl
    /builder/shared-workdir/build/staging_dir/toolchain-x86_64_gcc-8.4.0_musl
    /builder/shared-workdir/build/build_dir/toolchain-x86_64_gcc-8.4.0_musl;
    \\\n\tmkdir -p
    /builder/shared-workdir/build/staging_dir/toolchain-x86_64_gcc-8.4.0_musl/stamp;
    \\\n\tmv /builder/shared-workdir/build/tmp/.ver_check
    /builder/shared-workdir/build/staging_dir/toolchain-x86_64_gcc-8.4.0_musl/stamp/.ver_check;
    \\\n}\nx86_64

Only the last line contains the desired string.

Future investigation should check why the build system prints this to
stdout rather than stderr.

Signed-off-by: Paul Spooren <mail@aparcar.org>
scripts/json_overview_image_info.py

index e0e1ff08d598530c0a57f21cdd2e187ea6ef166a..cd814a19c0bdf1ec48e504f13603f9853aa16642 100755 (executable)
@@ -53,6 +53,8 @@ if output:
         [
             "make",
             "--no-print-directory",
+            "-C",
+            "target/linux/{}".format(output["target"].split("/")[0]),
             "val.ARCH_PACKAGES",
         ],
         stdout=PIPE,