tools: Improve diffability/maintainability
authorOlliver Schinagl <oliver@schinagl.nl>
Wed, 14 Dec 2022 10:33:01 +0000 (11:33 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Sat, 24 Dec 2022 10:54:10 +0000 (11:54 +0100)
There's no purpose to squish multiple tools into a single line (and
spread those out over multiple lines). It might look 'nice' in certain
conditions, but it's annoying to maintain.

For example, but not limited to:
* adding/removing tools, causes hard to read diffs
* Duplicates are harder to spot
* Sorting can not be (easily?) automated

With this proposed change, the above annoyances go away. Inserting a new
tool can be done with a single line-change-diff, sorting can be done by
any editor (in vi, select, :sort for example) and dupes are much easier
to spot.

Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
tools/Makefile

index 5ba15c641b42619e0b8a95cb5ada1282142f93fb..6300180d3f4a059ef6c14c672d0f4383ff3ab4c7 100644 (file)
@@ -21,11 +21,43 @@ ifneq ($(CONFIG_SDK)$(CONFIG_PACKAGE_kmod-b43)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),
   BUILD_B43_TOOLS = y
 endif
 
-tools-y += autoconf autoconf-archive automake bc bison cmake cpio dosfstools
-tools-y += e2fsprogs expat fakeroot findutils firmware-utils flex gengetopt
-tools-y += libressl libtool lzma m4 make-ext4fs meson missing-macros mkimage
-tools-y += mklibs mtd-utils mtools ninja padjffs2 patch-image
-tools-y += patchelf pkgconf quilt squashfskit4 sstrip zip zlib zstd
+tools-y += autoconf
+tools-y += autoconf-archive
+tools-y += automake
+tools-y += bc
+tools-y += bison
+tools-y += cmake
+tools-y += cpio
+tools-y += dosfstools
+tools-y += e2fsprogs
+tools-y += expat
+tools-y += fakeroot
+tools-y += findutils
+tools-y += firmware-utils
+tools-y += flex
+tools-y += gengetopt
+tools-y += libressl
+tools-y += libtool
+tools-y += lzma
+tools-y += m4
+tools-y += make-ext4fs
+tools-y += meson
+tools-y += missing-macros
+tools-y += mkimage
+tools-y += mklibs
+tools-y += mtd-utils
+tools-y += mtools
+tools-y += ninja
+tools-y += padjffs2
+tools-y += patch-image
+tools-y += patchelf
+tools-y += pkgconf
+tools-y += quilt
+tools-y += squashfskit4
+tools-y += sstrip
+tools-y += zip
+tools-y += zlib
+tools-y += zstd
 tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_B43_TOOLS),y) += b43-tools
 tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_ISL),y) += isl
 tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_TOOLCHAIN),y) += gmp mpc mpfr