libpcap: update to 1.20.2
authorNick Hainke <vincent@systemli.org>
Thu, 5 Jan 2023 10:08:27 +0000 (11:08 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 6 Jan 2023 15:20:06 +0000 (16:20 +0100)
A huge rewrite in libpcap was introduced by dc14a7babca1 ("rpcap: have
the server tell the client its byte order.") [0]. The patch
"201-space_optimization.patch" does not apply at all anymore. So remove
it.

Refresh:
- 100-no-openssl.patch
- 102-skip-manpages.patch

Update the "300-Add-support-for-B.A.T.M.A.N.-Advanced.patch" with latest
PR [1].

old ipkg size:
90964 bin/packages/mips_24kc/base/libpcap1_1.10.1-5_mips_24kc.ipk

new ipkg size:
93340 bin/packages/mips_24kc/base/libpcap1_1.10.2-1_mips_24kc.ipk

[0] - https://github.com/the-tcpdump-group/libpcap/commit/dc14a7babca1471809bee6872539ff836937840e
[1] - https://github.com/the-tcpdump-group/libpcap/pull/980

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/libs/libpcap/Makefile
package/libs/libpcap/patches/100-no-openssl.patch
package/libs/libpcap/patches/102-skip-manpages.patch
package/libs/libpcap/patches/201-space_optimization.patch [deleted file]
package/libs/libpcap/patches/300-Add-support-for-B.A.T.M.A.N.-Advanced.patch

index a94a7076489f9a51bdc9a0e129cc7072a03be1fb..67525c23261022540e386300f1b34c8c17213a4f 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpcap
-PKG_VERSION:=1.10.1
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=1.10.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.tcpdump.org/release/
-PKG_HASH:=ed285f4accaf05344f90975757b3dbfe772ba41d1c401c2648b7fa45b711bdd4
+PKG_HASH:=db6d79d4ad03b8b15fb16c42447d093ad3520c0ec0ae3d331104dcfb1ce77560
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=BSD-3-Clause
index 56896ad8ba1fa1156edc275765f55a841a26e342..434f1ce006ada9402da2dd131cf2d136251f0bed 100644 (file)
@@ -1,6 +1,6 @@
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -1042,7 +1042,6 @@ endif()
+@@ -1325,7 +1325,6 @@ endif()
  #
  # OpenSSL/libressl.
  #
index 79a365643e24b72a337cff1bad462c6bfafe7808..43d393ac5f67b6662498463c63238bece560f0d3 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH] skip manpages
 
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -2732,57 +2732,6 @@ if(NOT MSVC)
+@@ -3325,57 +3325,6 @@ if(NOT MSVC)
      if(MINGW)
          find_program(LINK_EXECUTABLE ln)
      endif(MINGW)
diff --git a/package/libs/libpcap/patches/201-space_optimization.patch b/package/libs/libpcap/patches/201-space_optimization.patch
deleted file mode 100644 (file)
index bf9374d..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/pcap-common.c
-+++ b/pcap-common.c
-@@ -1662,14 +1662,23 @@ swap_pseudo_headers(int linktype, struct
-               break;
-       case DLT_USB_LINUX:
-+#ifndef PCAP_SUPPORT_USB
-+              return;
-+#endif
-               swap_linux_usb_header(hdr, data, 0);
-               break;
-       case DLT_USB_LINUX_MMAPPED:
-+#ifndef PCAP_SUPPORT_USB
-+              return;
-+#endif
-               swap_linux_usb_header(hdr, data, 1);
-               break;
-       case DLT_NFLOG:
-+#ifndef PCAP_SUPPORT_NETFILTER
-+              return;
-+#endif
-               swap_nflog_header(hdr, data);
-               break;
-       }
index ce8106570373e6e8246effc8cdd9cfb8a69d128c..0a6aa3c0b7bab4a942f179c935fff6ec24a54e09 100644 (file)
@@ -1,4 +1,4 @@
-From b86b960fbd5c215c9c0f43544935b9a25d9445c5 Mon Sep 17 00:00:00 2001
+From 3d8d268320d2381021a409ff8d03533698dd6242 Mon Sep 17 00:00:00 2001
 From: =?UTF-8?q?Linus=20L=C3=BCssing?= <linus.luessing@c0d3.blue>
 Date: Mon, 23 Nov 2020 00:38:22 +0100
 Subject: [PATCH] Add support for B.A.T.M.A.N. Advanced
@@ -220,16 +220,16 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  #endif
 --- a/gencode.c
 +++ b/gencode.c
-@@ -74,6 +74,8 @@
- #include "atmuni31.h"
+@@ -60,6 +60,8 @@
  #include "sunatmpos.h"
+ #include "pflog.h"
  #include "ppp.h"
 +#include "batadv_packet.h"
 +#include "batadv_legacy_packet.h"
  #include "pcap/sll.h"
  #include "pcap/ipnet.h"
  #include "arcnet.h"
-@@ -9501,6 +9503,168 @@ gen_geneve(compiler_state_t *cstate, bpf
+@@ -9436,6 +9438,168 @@ gen_geneve(compiler_state_t *cstate, bpf
        return b1;
  }
  
@@ -400,7 +400,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  static struct block *
 --- a/gencode.h
 +++ b/gencode.h
-@@ -346,6 +346,9 @@ struct block *gen_pppoes(compiler_state_
+@@ -358,6 +358,9 @@ struct block *gen_pppoes(compiler_state_
  
  struct block *gen_geneve(compiler_state_t *, bpf_u_int32, int);
  
@@ -412,7 +412,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  struct block *gen_atmtype_abbrev(compiler_state_t *, int);
 --- a/grammar.y.in
 +++ b/grammar.y.in
-@@ -347,6 +347,7 @@ DIAG_OFF_BISON_BYACC
+@@ -375,6 +375,7 @@ DIAG_OFF_BISON_BYACC
  %type <i>     mtp2type
  %type <blk>   mtp3field
  %type <blk>   mtp3fieldvalue mtp3value mtp3listvalue
@@ -420,7 +420,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  
  
  %token  DST SRC HOST GATEWAY
-@@ -365,7 +366,7 @@ DIAG_OFF_BISON_BYACC
+@@ -393,7 +394,7 @@ DIAG_OFF_BISON_BYACC
  %token  LEN
  %token  IPV6 ICMPV6 AH ESP
  %token        VLAN MPLS
@@ -429,7 +429,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  %token  ISO ESIS CLNP ISIS L1 L2 IIH LSP SNP CSNP PSNP
  %token  STP
  %token  IPX
-@@ -592,11 +593,40 @@ other:     pqual TK_BROADCAST    { CHECK_PTR_
+@@ -620,11 +621,40 @@ other:     pqual TK_BROADCAST    { CHECK_PTR_
        | PPPOES                { CHECK_PTR_VAL(($$ = gen_pppoes(cstate, 0, 0))); }
        | GENEVE pnum           { CHECK_PTR_VAL(($$ = gen_geneve(cstate, $2, 1))); }
        | GENEVE                { CHECK_PTR_VAL(($$ = gen_geneve(cstate, 0, 0))); }
@@ -556,15 +556,15 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
        }
 --- a/pcap-filter.manmisc.in
 +++ b/pcap-filter.manmisc.in
-@@ -98,6 +98,7 @@ protos are:
+@@ -98,6 +98,7 @@ protocols are:
  .BR arp ,
  .BR rarp ,
  .BR decnet ,
 +.BR batadv ,
+ .BR sctp ,
  .B tcp
  and
- .BR udp .
-@@ -361,7 +362,7 @@ True if the packet is an IPv6 multicast
+@@ -400,7 +401,7 @@ True if the packet is an IPv6 multicast
  .IP  "\fBether proto \fIprotocol\fR"
  True if the packet is of ether type \fIprotocol\fR.
  \fIProtocol\fP can be a number or one of the names
@@ -573,7 +573,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  \fBipx\fP, \fBiso\fP, \fBlat\fP, \fBloopback\fP, \fBmopdl\fP, \fBmoprc\fP, \fBnetbeui\fP,
  \fBrarp\fP, \fBsca\fP or \fBstp\fP.
  Note these identifiers (except \fBloopback\fP) are also keywords
-@@ -415,7 +416,7 @@ the filter checks for the IPX etype in a
+@@ -454,7 +455,7 @@ the filter checks for the IPX etype in a
  DSAP in the LLC header, the 802.3-with-no-LLC-header encapsulation of
  IPX, and the IPX etype in a SNAP frame.
  .RE
@@ -582,7 +582,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  Abbreviations for:
  .in +.5i
  .nf
-@@ -752,6 +753,36 @@ For example:
+@@ -792,6 +793,36 @@ For example:
  filters IPv4 protocol encapsulated in Geneve with VNI 0xb. This will
  match both IPv4 directly encapsulated in Geneve as well as IPv4 contained
  inside an Ethernet frame.
@@ -621,7 +621,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  \fIProtocol\fP can be a number or one of the names
 --- a/pcap/namedb.h
 +++ b/pcap/namedb.h
-@@ -69,6 +69,8 @@ PCAP_API int pcap_nametoportrange(const
+@@ -70,6 +70,8 @@ PCAP_API int pcap_nametoportrange(const
  PCAP_API int  pcap_nametoproto(const char *);
  PCAP_API int  pcap_nametoeproto(const char *);
  PCAP_API int  pcap_nametollc(const char *);
@@ -632,7 +632,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
   * Also, pcap_nametoport() returns the protocol along with the port number.
 --- a/scanner.l
 +++ b/scanner.l
-@@ -344,6 +344,7 @@ mpls               return MPLS;
+@@ -347,6 +347,7 @@ mpls               return MPLS;
  pppoed                return PPPOED;
  pppoes                return PPPOES;
  geneve                return GENEVE;