image: update LZMA_XZ_OPTIONS with new squashfs4 tool
authorChristian Marangi <ansuelsmth@gmail.com>
Mon, 6 Feb 2023 22:28:14 +0000 (23:28 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 20 Feb 2023 06:34:07 +0000 (07:34 +0100)
The -Xpreset option changed format and dropped the -Xe and just require
the extreme string to be passed to the -Xpreset option.

Update the LZMA_XZ_OPTIONS to reflect this change.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/image.mk

index b801ef993c310c1acafb4b635211e585dddeb588..ef242db96e554e92f57b66faed9f07256e77b1e7 100644 (file)
@@ -77,7 +77,7 @@ SQUASHFSOPT := -b $(SQUASHFS_BLOCKSIZE)
 SQUASHFSOPT += -p '/dev d 755 0 0' -p '/dev/console c 600 0 0 5 1'
 SQUASHFSOPT += $(if $(CONFIG_SELINUX),-xattrs,-no-xattrs)
 SQUASHFSCOMP := gzip
-LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
+LZMA_XZ_OPTIONS := -Xpreset extreme -Xlc 0 -Xlp 2 -Xpb 2
 ifeq ($(CONFIG_SQUASHFS_XZ),y)
   ifneq ($(filter arm x86 powerpc sparc,$(LINUX_KARCH)),)
     BCJ_FILTER:=-Xbcj $(LINUX_KARCH)