tools/autoconf: clean up build recipes
authorMichael Pratt <mcpratt@pm.me>
Wed, 7 Sep 2022 14:06:15 +0000 (10:06 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Mar 2023 21:53:41 +0000 (22:53 +0100)
The configure option datarootdir
defaults to PREFIX/share.

The Host/Clean define should be Host/Uninstall
otherwise it is removing the build directory
before there is a chance to try "make uninstall"
in that directory.
Host/Clean/Default is no longer defined.

Use default build recipes defined in host-build.mk
instead of custom ones that are equivalent.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/autoconf/Makefile

index 6eb64d77d5127200f87d9f22e3b9c7199dab578b..b9c2f93ff3dbd879ec977cb3063760f3d0da14a7 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -15,23 +15,15 @@ PKG_HASH:=64ebcec9f8ac5b2487125a86a7760d2591ac9e1d3dbd59489633f9de62a57684
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_CONFIGURE_ARGS += \
-       --datarootdir=$(STAGING_DIR_HOST)/share
-
 HOST_CONFIGURE_VARS += \
        PERL="/usr/bin/env perl"
 
 define Host/Compile
-       export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
-       export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Compile/Default)
 endef
 
-define Host/Clean
-       -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
 endef
 
 $(eval $(call HostBuild))