base-files: rename 'sdcard' to 'legacy-sdcard'
authorDaniel Golle <daniel@makrotopia.org>
Sat, 7 Aug 2021 13:30:53 +0000 (14:30 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 16 Aug 2021 11:22:17 +0000 (12:22 +0100)
While an image layout based on MBR and 'bootfs' partition may be easy
to understand for users who are very used to the IBM PC and always have
the option to access the SD card outside of the device (and hence don't
really depend on other recovery methods or dual-boot), in my opinion
it's a dead end for many desirable features on embedded systems,
especially when managed remotely (and hence without an easy option to
access the SD card using another device in case things go wrong, for
example).

Let me explain:

* using a MSDOS/VFAT filesystem to store kernel(s) is problematic, as a
  single corruption of the bootfs can render the system into a state
  that it no longer boots at all. This makes dual-boot useless, or at
  least very tedious to setup with then 2 independent boot partitions
  to avoid the single point of failure on a "hot" block (the FAT index
  of the boot partition, written every time a file is changed in
  bootfs). And well: most targets even store the bootloader environment
  in a file in that very same FAT filesystem, hence it cannot be used
  to script a reliable dual-boot method (as loading the environment
  itself will already fail if the filesystem is corrupted).

* loading the kernel uImage from bootfs and using rootfs inside an
  additional partition means the bootloader can only validate the
  kernel -- if rootfs is broken or corrupted, this can lead to a reboot
  loop, which is often a quite costly thing to happen in terms of
  hardware lifetime.

* imitating MBR-boot behavior with a FAT-formatted bootfs partition
  (like IBM PC in the 80s and 90s) is just one of many choices on
  embedded targets. There are much better options with modern U-Boot
  (which is what we use and build from source for all targets booting
  off SD cards), see examples in mediatek/mt7622 and mediatek/mt7623.

Hence rename the 'sdcard' feature to 'legacy-sdcard', and prefix
functions with 'legacy_sdcard_' instead of 'sdcard_'.

Tested-by: Stijn Tintel <stijn@linux-ipv6.be>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/base-files/Makefile
package/base-files/files/lib/upgrade/legacy-sdcard.sh [new file with mode: 0644]
package/base-files/files/lib/upgrade/sdcard.sh [deleted file]
scripts/target-metadata.pl
target/Config.in
target/linux/mvebu/Makefile
target/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh
target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh

index f19b07cfe12266c95b50714d5ae546568f8d719b..d67f551b9c5513181b8e2a9db8d83830b59c61fb 100644 (file)
@@ -23,7 +23,7 @@ PKG_LICENSE:=GPL-2.0
 PKG_CONFIG_DEPENDS += \
        CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE \
        CONFIG_NAND_SUPPORT \
-       CONFIG_SDCARD_SUPPORT \
+       CONFIG_LEGACY_SDCARD_SUPPORT \
        CONFIG_CLEAN_IPKG \
        CONFIG_PER_FEED_REPO \
        $(foreach feed,$(FEEDS_AVAILABLE),CONFIG_FEED_$(feed))
@@ -124,9 +124,9 @@ ifeq ($(CONFIG_NAND_SUPPORT),)
   endef
 endif
 
-ifeq ($(CONFIG_SDCARD_SUPPORT),)
-  define Package/base-files/sdcard-support
-       rm -f $(1)/lib/upgrade/sdcard.sh
+ifeq ($(CONFIG_LEGACY_SDCARD_SUPPORT),)
+  define Package/base-files/legacy-sdcard-support
+       rm -f $(1)/lib/upgrade/legacy-sdcard.sh
   endef
 endif
 
@@ -135,7 +135,7 @@ define Package/base-files/install
        $(CP) ./files/* $(1)/
        $(Package/base-files/install-key)
        $(Package/base-files/nand-support)
-       $(Package/base-files/sdcard-support)
+       $(Package/base-files/legacy-sdcard-support)
        if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
                $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
        fi
diff --git a/package/base-files/files/lib/upgrade/legacy-sdcard.sh b/package/base-files/files/lib/upgrade/legacy-sdcard.sh
new file mode 100644 (file)
index 0000000..d2ae53b
--- /dev/null
@@ -0,0 +1,91 @@
+legacy_sdcard_check_image() {
+       local file="$1"
+       local diskdev partdev diff
+
+       export_bootdevice && export_partdevice diskdev 0 || {
+               v "Unable to determine upgrade device"
+       return 1
+       }
+
+       get_partitions "/dev/$diskdev" bootdisk
+
+       v "Extract boot sector from the image"
+       get_image_dd "$1" of=/tmp/image.bs count=1 bs=512b
+
+       get_partitions /tmp/image.bs image
+
+       #compare tables
+       diff="$(grep -F -x -v -f /tmp/partmap.bootdisk /tmp/partmap.image)"
+
+       rm -f /tmp/image.bs /tmp/partmap.bootdisk /tmp/partmap.image
+
+       if [ -n "$diff" ]; then
+               v "Partition layout has changed. Full image will be written."
+               ask_bool 0 "Abort" && exit 1
+               return 0
+       fi
+}
+
+legacy_sdcard_do_upgrade() {
+       local board=$(board_name)
+       local diskdev partdev diff
+
+       export_bootdevice && export_partdevice diskdev 0 || {
+               v "Unable to determine upgrade device"
+       return 1
+       }
+
+       sync
+
+       if [ "$UPGRADE_OPT_SAVE_PARTITIONS" = "1" ]; then
+               get_partitions "/dev/$diskdev" bootdisk
+
+               v "Extract boot sector from the image"
+               get_image_dd "$1" of=/tmp/image.bs count=1 bs=512b
+
+               get_partitions /tmp/image.bs image
+
+               #compare tables
+               diff="$(grep -F -x -v -f /tmp/partmap.bootdisk /tmp/partmap.image)"
+       else
+               diff=1
+       fi
+
+       if [ -n "$diff" ]; then
+               get_image_dd "$1" of="/dev/$diskdev" bs=4096 conv=fsync
+
+               # Separate removal and addtion is necessary; otherwise, partition 1
+               # will be missing if it overlaps with the old partition 2
+               partx -d - "/dev/$diskdev"
+               partx -a - "/dev/$diskdev"
+       else
+               v "Writing bootloader to /dev/$diskdev"
+               get_image_dd "$1" of="$diskdev" bs=512 skip=1 seek=1 count=2048 conv=fsync
+               #iterate over each partition from the image and write it to the boot disk
+               while read part start size; do
+                       if export_partdevice partdev $part; then
+                               v "Writing image to /dev/$partdev..."
+                               get_image_dd "$1" of="/dev/$partdev" ibs="512" obs=1M skip="$start" count="$size" conv=fsync
+                       else
+                               v "Unable to find partition $part device, skipped."
+                       fi
+               done < /tmp/partmap.image
+
+               v "Writing new UUID to /dev/$diskdev..."
+               get_image_dd "$1" of="/dev/$diskdev" bs=1 skip=440 count=4 seek=440 conv=fsync
+       fi
+
+       sleep 1
+}
+
+legacy_sdcard_copy_config() {
+       local partdev
+
+       if export_partdevice partdev 1; then
+               mkdir -p /boot
+               [ -f /boot/kernel.img ] || mount -o rw,noatime /dev/$partdev /boot
+               cp -af "$UPGRADE_BACKUP" "/boot/$BACKUP_FILE"
+               sync
+               umount /boot
+       fi
+}
diff --git a/package/base-files/files/lib/upgrade/sdcard.sh b/package/base-files/files/lib/upgrade/sdcard.sh
deleted file mode 100644 (file)
index 2052805..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-sdcard_check_image() {
-       local file="$1"
-       local diskdev partdev diff
-
-       export_bootdevice && export_partdevice diskdev 0 || {
-               v "Unable to determine upgrade device"
-       return 1
-       }
-
-       get_partitions "/dev/$diskdev" bootdisk
-
-       v "Extract boot sector from the image"
-       get_image_dd "$1" of=/tmp/image.bs count=1 bs=512b
-
-       get_partitions /tmp/image.bs image
-
-       #compare tables
-       diff="$(grep -F -x -v -f /tmp/partmap.bootdisk /tmp/partmap.image)"
-
-       rm -f /tmp/image.bs /tmp/partmap.bootdisk /tmp/partmap.image
-
-       if [ -n "$diff" ]; then
-               v "Partition layout has changed. Full image will be written."
-               ask_bool 0 "Abort" && exit 1
-               return 0
-       fi
-}
-
-sdcard_do_upgrade() {
-       local board=$(board_name)
-       local diskdev partdev diff
-
-       export_bootdevice && export_partdevice diskdev 0 || {
-               v "Unable to determine upgrade device"
-       return 1
-       }
-
-       sync
-
-       if [ "$UPGRADE_OPT_SAVE_PARTITIONS" = "1" ]; then
-               get_partitions "/dev/$diskdev" bootdisk
-
-               v "Extract boot sector from the image"
-               get_image_dd "$1" of=/tmp/image.bs count=1 bs=512b
-
-               get_partitions /tmp/image.bs image
-
-               #compare tables
-               diff="$(grep -F -x -v -f /tmp/partmap.bootdisk /tmp/partmap.image)"
-       else
-               diff=1
-       fi
-
-       if [ -n "$diff" ]; then
-               get_image_dd "$1" of="/dev/$diskdev" bs=4096 conv=fsync
-
-               # Separate removal and addtion is necessary; otherwise, partition 1
-               # will be missing if it overlaps with the old partition 2
-               partx -d - "/dev/$diskdev"
-               partx -a - "/dev/$diskdev"
-       else
-               v "Writing bootloader to /dev/$diskdev"
-               get_image_dd "$1" of="$diskdev" bs=512 skip=1 seek=1 count=2048 conv=fsync
-               #iterate over each partition from the image and write it to the boot disk
-               while read part start size; do
-                       if export_partdevice partdev $part; then
-                               v "Writing image to /dev/$partdev..."
-                               get_image_dd "$1" of="/dev/$partdev" ibs="512" obs=1M skip="$start" count="$size" conv=fsync
-                       else
-                               v "Unable to find partition $part device, skipped."
-                       fi
-               done < /tmp/partmap.image
-
-               v "Writing new UUID to /dev/$diskdev..."
-               get_image_dd "$1" of="/dev/$diskdev" bs=1 skip=440 count=4 seek=440 conv=fsync
-       fi
-
-       sleep 1
-}
-
-sdcard_copy_config() {
-       local partdev
-
-       if export_partdevice partdev 1; then
-               mkdir -p /boot
-               [ -f /boot/kernel.img ] || mount -o rw,noatime /dev/$partdev /boot
-               cp -af "$UPGRADE_BACKUP" "/boot/$BACKUP_FILE"
-               sync
-               umount /boot
-       fi
-}
index 34fb32a07e6d8580d7098cbef437afd48a9cae63..163eb3768bdea294bcc5731a2e17dee031b94174 100755 (executable)
@@ -22,6 +22,7 @@ sub target_config_features(@) {
                /^gpio$/ and $ret .= "\tselect GPIO_SUPPORT\n";
                /^jffs2$/ and $ret .= "\tselect USES_JFFS2\n";
                /^jffs2_nand$/ and $ret .= "\tselect USES_JFFS2_NAND\n";
+               /^legacy-sdcard$/ and $ret .= "\tselect LEGACY_SDCARD_SUPPORT\n";
                /^low_mem$/ and $ret .= "\tselect LOW_MEMORY_FOOTPRINT\n";
                /^minor$/ and $ret .= "\tselect USES_MINOR\n";
                /^mips16$/ and $ret .= "\tselect HAS_MIPS16\n";
@@ -36,7 +37,6 @@ sub target_config_features(@) {
                /^rfkill$/ and $ret .= "\tselect RFKILL_SUPPORT\n";
                /^rootfs-part$/ and $ret .= "\tselect USES_ROOTFS_PART\n";
                /^rtc$/ and $ret .= "\tselect RTC_SUPPORT\n";
-               /^sdcard$/ and $ret .= "\tselect SDCARD_SUPPORT\n";
                /^separate_ramdisk$/ and $ret .= "\tselect USES_INITRAMFS\n\tselect USES_SEPARATE_INITRAMFS\n";
                /^small_flash$/ and $ret .= "\tselect SMALL_FLASH\n";
                /^spe_fpu$/ and $ret .= "\tselect HAS_SPE_FPU\n";
index fde7ea4137497b6dafcd2172a4f59956ca28496f..32242446ee6c49743cc619105d03240a7799a5f2 100644 (file)
@@ -101,7 +101,7 @@ config RFKILL_SUPPORT
 config NAND_SUPPORT
        bool
 
-config SDCARD_SUPPORT
+config LEGACY_SDCARD_SUPPORT
        bool
 
 config ARCH_64BIT
index 6b992f890392dc5d4e27330923e6b655e1c955fc..3737a4aa23b10c3840ef7b5fd0005bd337f7505f 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=mvebu
 BOARDNAME:=Marvell EBU Armada
-FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part sdcard
+FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part legacy-sdcard
 SUBTARGETS:=cortexa9 cortexa53 cortexa72
 
 KERNEL_PATCHVER:=5.4
index 26bb02241510eaa921426b561df9df412e6411dc..0ee1d61506fbd63a851b150e0944180fc0d7e082 100755 (executable)
@@ -15,7 +15,7 @@ platform_check_image() {
        globalscale,espressobin-ultra|\
        globalscale,espressobin-v7|\
        globalscale,espressobin-v7-emmc)
-               sdcard_check_image "$1"
+               legacy_sdcard_check_image "$1"
                ;;
        *)
                return 0
@@ -31,7 +31,7 @@ platform_do_upgrade() {
        globalscale,espressobin-ultra|\
        globalscale,espressobin-v7|\
        globalscale,espressobin-v7-emmc)
-               sdcard_do_upgrade "$1"
+               legacy_sdcard_do_upgrade "$1"
                ;;
        methode,udpu)
                platform_do_upgrade_uDPU "$1"
@@ -49,7 +49,7 @@ platform_copy_config() {
        globalscale,espressobin-ultra|\
        globalscale,espressobin-v7|\
        globalscale,espressobin-v7-emmc)
-               sdcard_copy_config
+               legacy_sdcard_copy_config
                ;;
        methode,udpu)
                platform_copy_config_uDPU
index 1713f55b72a3e2a20621c477ba4b825716b9ce95..74aad434ea0f7ba00a0795af354dce2505815c41 100755 (executable)
@@ -11,7 +11,7 @@ platform_check_image() {
        case "$(board_name)" in
        marvell,armada8040-mcbin-doubleshot|\
        marvell,armada8040-mcbin-singleshot)
-               sdcard_check_image "$1"
+               legacy_sdcard_check_image "$1"
                ;;
        *)
                return 0
@@ -23,7 +23,7 @@ platform_do_upgrade() {
        case "$(board_name)" in
        marvell,armada8040-mcbin-doubleshot|\
        marvell,armada8040-mcbin-singleshot)
-               sdcard_do_upgrade "$1"
+               legacy_sdcard_do_upgrade "$1"
                ;;
        *)
                default_do_upgrade "$1"
@@ -34,7 +34,7 @@ platform_copy_config() {
        case "$(board_name)" in
        marvell,armada8040-mcbin-doubleshot|\
        marvell,armada8040-mcbin-singleshot)
-               sdcard_copy_config
+               legacy_sdcard_copy_config
                ;;
        esac
 }
index bf3961c4373cf0b30e9e17e3b554a6e0c05c9560..5e69374837778f22b898db3df7e535265a89031b 100755 (executable)
@@ -13,7 +13,7 @@ platform_check_image() {
        kobol,helios4|\
        solidrun,clearfog-base-a1|\
        solidrun,clearfog-pro-a1)
-               sdcard_check_image "$1"
+               legacy_sdcard_check_image "$1"
                ;;
        *)
                return 0
@@ -30,7 +30,7 @@ platform_do_upgrade() {
        kobol,helios4|\
        solidrun,clearfog-base-a1|\
        solidrun,clearfog-pro-a1)
-               sdcard_do_upgrade "$1"
+               legacy_sdcard_do_upgrade "$1"
                ;;
        linksys,wrt1200ac|\
        linksys,wrt1900ac-v1|\
@@ -51,7 +51,7 @@ platform_copy_config() {
        kobol,helios4|\
        solidrun,clearfog-base-a1|\
        solidrun,clearfog-pro-a1)
-               sdcard_copy_config
+               legacy_sdcard_copy_config
                ;;
        linksys,wrt1200ac|\
        linksys,wrt1900ac-v1|\