prereq-build: use RequireCHeader test for ncurses prereq
authorChristian Marangi <ansuelsmth@gmail.com>
Mon, 9 Jan 2023 17:40:00 +0000 (18:40 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 9 Jan 2023 20:25:06 +0000 (21:25 +0100)
RequireCHeader is a generilized version of the ncurses prereq test. Use
that indetad.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/prereq-build.mk

index 9c4ef547ad04d28bf5f24e4a4791cc2efdb2ae6b..7959890eb52e9174319e2307f8f644bc881a040b 100644 (file)
@@ -49,10 +49,9 @@ $(eval $(call TestHostCommand,working-g++, \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
 
-$(eval $(call TestHostCommand,ncurses, \
+$(eval $(call RequireCHeader,ncurses.h, \
        Please install ncurses. (Missing libncurses.so or ncurses.h), \
-       echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
-               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
+       initscr(), -lncurses))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule, \