at91: fix build error for wb50n.
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Mon, 2 Apr 2018 16:34:07 +0000 (09:34 -0700)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Apr 2018 07:01:12 +0000 (09:01 +0200)
when external kernel is selected from menuconfig, device wb50n is not
avaliable and build fails. As a fix adding checks for external kernel.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
target/linux/at91/image/sama5.mk

index e51a0bce20d9bc97feb5adfa9defd58a21229a63..5b518c97671029303b2ab36ec634e2480cff2792 100644 (file)
@@ -71,16 +71,20 @@ define Device/at91-sama5d4_xplained
 endef
 TARGET_DEVICES += at91-sama5d4_xplained
 
-define Device/wb50n
-  $(Device/evaluation-fit)
-  DEVICE_TITLE := Laird WB50N
-  DEVICE_PACKAGES := \
+ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+  define Device/wb50n
+    $(Device/evaluation-fit)
+    DEVICE_TITLE := Laird WB50N
+    DEVICE_PACKAGES := \
          kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
          kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
          kmod-leds-gpio
-  BLOCKSIZE := 128k
-  PAGESIZE := 2048
-  SUBPAGESIZE := 2048
-  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
-endef
-TARGET_DEVICES += wb50n
+    BLOCKSIZE := 128k
+    PAGESIZE := 2048
+    SUBPAGESIZE := 2048
+    MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+  endef
+  TARGET_DEVICES += wb50n
+ endif
+endif