mt7621: netgear_ex6150: fix reboot loop by using LZMA loader
authorPetr Štetiar <ynezz@true.cz>
Tue, 18 Oct 2022 06:55:46 +0000 (08:55 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 18 Oct 2022 07:01:39 +0000 (09:01 +0200)
This fixes a well known "LZMA ERROR 1" error, reported previously on
numerous of similar devices.

Fixes: #10645
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ramips/image/mt7621.mk

index c4a033b8dcb366961de6d5907b7b7d74a7477e2e..f7bb0590d75f14aed891face2f43a5f6ec6abe33 100644 (file)
@@ -1391,6 +1391,7 @@ TARGET_DEVICES += mts_wg430223
 
 define Device/netgear_ex6150
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   DEVICE_VENDOR := NETGEAR
   DEVICE_MODEL := EX6150
   DEVICE_PACKAGES := kmod-mt76x2