tools/libtool: clean up build recipes
authorMichael Pratt <mcpratt@pm.me>
Wed, 15 Mar 2023 05:45:02 +0000 (01:45 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Mar 2023 22:41:50 +0000 (00:41 +0200)
Host/Clean/Default is no longer defined.

Use the uninstall makefile target
to remove the obsolete m4 files, and more.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/libtool/Makefile

index cc9e8a68fbd86f70b96f8bf307bf5db8a57b2c63..b4f3ecc36ba347a75b50934eb2ddf27b0c5039c1 100644 (file)
@@ -23,7 +23,7 @@ HOST_CONFIGURE_VARS += \
 
 define Host/Prepare
        $(call Host/Prepare/Default)
-       (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
+       $(call Host/Uninstall)
        $(if $(QUILT),,(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
 endef
 
@@ -33,16 +33,13 @@ define Host/Configure
 endef
 
 define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Compile/Default,install)
        $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool
 endef
 
 define Host/Uninstall
        -$(call Host/Compile/Default,uninstall)
-endef
-
-define Host/Clean
-       $(call Host/Clean/Default)
+       (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
 endef
 
 $(eval $(call HostBuild))