ipq40xx: convert AP-365 to DSA
authorDavid Bauer <mail@david-bauer.net>
Wed, 12 Apr 2023 20:06:18 +0000 (22:06 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sat, 15 Apr 2023 12:15:42 +0000 (14:15 +0200)
Re-enable the Aruba AP-365 with DSA support. Changes are trvivial, as
the board design is pretty much the already updated AP-303.

Run-tested on the device.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/image/generic.mk

index 37b9ca268bfd5740811f643c0ca1ce4d3b2dd98f..7c9c2f0827829f146f6fa25f6d7a757808c0a357 100644 (file)
@@ -45,6 +45,7 @@ ipq40xx_setup_interfaces()
                ucidef_set_interfaces_lan_wan "lan" "wan"
                ;;
        aruba,ap-303|\
+       aruba,ap-365|\
        avm,fritzrepeater-1200|\
        dlink,dap-2610|\
        extreme-networks,ws-ap3915i|\
index 48514b88416275a05d831825a8a9eb2b4ef73c65..2f0ca927f01aa20d9b75217416331b83c3a58677 100644 (file)
@@ -190,8 +190,7 @@ define Device/aruba_ap-365
        DEVICE_MODEL := AP-365
        DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += aruba_ap-365
+TARGET_DEVICES += aruba_ap-365
 
 define Device/asus_map-ac2200
        $(call Device/FitImageLzma)