openssl: update to 1.0.2r
authorStijn Segers <foss@volatilesystems.org>
Sat, 6 Apr 2019 21:16:31 +0000 (23:16 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Sun, 7 Apr 2019 17:39:26 +0000 (19:39 +0200)
This bump contains bug and security fixes.

Compile-tested on ar71xx, ramips/mt7621 and x86/64.
Run-tested on ramips/mt7621.

Signed-off-by: Stijn Segers <foss@volatilesystems.org>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_HASH fixup]
package/libs/openssl/Makefile
package/libs/openssl/patches/200-parallel_build.patch

index a4781e9eeea0bd855d001b592b760917d4ef608d..2902ce15c76b41fe200e507300aa24c29b791932 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_BASE:=1.0.2
-PKG_BUGFIX:=q
+PKG_BUGFIX:=r
 PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
@@ -24,7 +24,7 @@ PKG_SOURCE_URL:= \
        http://gd.tuwien.ac.at/infosys/security/openssl/source/ \
        http://www.openssl.org/source/ \
        http://www.openssl.org/source/old/$(PKG_BASE)/
-PKG_HASH:=5744cfcbcec2b1b48629f7354203bc1e5e9b5466998bbccc5b5fcde3b18eb684
+PKG_HASH:=ae51d08bba8a83958e894946f15303ff894d75c2b8bbd44a852b64e3fe11d0d6
 
 PKG_LICENSE:=OpenSSL
 PKG_LICENSE_FILES:=LICENSE
index 37134e403038bb03f15fc2c0aa1b57a027231678..cbe5d5124180338e4495b9d74a8b96e98341ee4b 100644 (file)
@@ -92,7 +92,7 @@
                fi; \
 --- a/crypto/Makefile
 +++ b/crypto/Makefile
-@@ -85,11 +85,11 @@ testapps:
+@@ -87,11 +87,11 @@ testapps:
        @if [ -z "$(THIS)" ]; then $(MAKE) -f $(TOP)/Makefile reflect THIS=$@; fi
  
  subdirs:
  
  links:
        @$(PERL) $(TOP)/util/mklink.pl ../include/openssl $(EXHEADER)
-@@ -100,7 +100,7 @@ links:
+@@ -102,7 +102,7 @@ links:
  # lib: $(LIB): are splitted to avoid end-less loop
  lib:  $(LIB)
        @touch lib
        $(AR) $(LIB) $(LIBOBJ)
        test -z "$(FIPSLIBDIR)" || $(AR) $(LIB) $(FIPSLIBDIR)fipscanister.o
        $(RANLIB) $(LIB) || echo Never mind.
-@@ -111,7 +111,7 @@ shared: buildinf.h lib subdirs
+@@ -113,7 +113,7 @@ shared: buildinf.h lib subdirs
        fi
  
  libs:
  
  install:
        @[ -n "$(INSTALLTOP)" ] # should be set by top Makefile...
-@@ -120,7 +120,7 @@ install:
+@@ -122,7 +122,7 @@ install:
        (cp $$i $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl/$$i; \
        chmod 644 $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl/$$i ); \
        done;