kernel/module/iio: add TI am335x ADC driver
authorAlexander Couzens <lynxis@fe80.eu>
Mon, 21 Nov 2022 14:46:42 +0000 (14:46 +0000)
committerAlexander Couzens <lynxis@fe80.eu>
Thu, 24 Nov 2022 15:47:01 +0000 (15:47 +0000)
Add the iio driver for the embedded ADC in the
TI Sitara am335x SoCs.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/kernel/linux/modules/iio.mk

index afd14ef47beb4ff131fee84605ce7979af4d7dba..c0e37f06c7455e8a2584128094cf2dec3720affe 100644 (file)
@@ -566,3 +566,17 @@ define KernelPackage/iio-fxos8700-spi/description
 endef
 
 $(eval $(call KernelPackage,iio-fxos8700-spi))
+
+define KernelPackage/iio-ti-am335x-adc
+  TITLE:= TI Sitara AM335x ADC driver
+  DEPENDS:=@TARGET_omap
+  KCONFIG:=CONFIG_TI_AM335X_ADC
+  FILES:=$(LINUX_DIR)/drivers/iio/adc/ti_am335x_adc.ko
+  AUTOLOAD:=$(call AutoProbe,ti_am335x_adc)
+  $(call AddDepends/iio,+kmod-iio-kfifo-buf)
+endef
+define KernelPackage/iio-ti-am335x-adc/description
+ Driver for the TI AM335x ADC.
+endef
+
+$(eval $(call KernelPackage,iio-ti-am335x-adc))