mbedtls: update to version 2.16.1
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 17 May 2019 20:20:09 +0000 (22:20 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 30 May 2019 10:15:20 +0000 (12:15 +0200)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/libs/mbedtls/Makefile
package/libs/mbedtls/patches/200-config.patch
package/libs/mbedtls/patches/300-bn_mul.h-Use-optimized-MULADDC-code-only-on-ARM-6.patch
package/libs/mbedtls/patches/300-soversion-compatibility.patch

index e265cac575a9cb0bb16b24be04b68b46fa08d50f..401be59d64f07abc3e6ceee669e1022baac86585 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mbedtls
-PKG_VERSION:=2.14.1
+PKG_VERSION:=2.16.1
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
 PKG_SOURCE_URL:=https://tls.mbed.org/download/
-PKG_HASH:=baa1121952786f5b2c66c52226a8ca0e05126de920d1756266551df677915b7e
+PKG_HASH:=7ab76eaefab0b02f26ca889230d553facb2598f3a8f077886c41ec1801d2131a
 
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0+
index a9cd62fc399c2124fb5daca7070571f55ba5e618..3793758a8e39465368a888219336cec13f30a9b9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/mbedtls/config.h
 +++ b/include/mbedtls/config.h
-@@ -557,14 +557,14 @@
+@@ -599,14 +599,14 @@
   *
   * Enable Output Feedback mode (OFB) for symmetric ciphers.
   */
@@ -17,7 +17,7 @@
  
  /**
   * \def MBEDTLS_CIPHER_NULL_CIPHER
-@@ -654,19 +654,19 @@
+@@ -716,19 +716,19 @@
   *
   * Comment macros to disable the curve and functions for it
   */
@@ -46,7 +46,7 @@
  
  /**
   * \def MBEDTLS_ECP_NIST_OPTIM
-@@ -682,7 +682,7 @@
+@@ -777,7 +777,7 @@
   *
   * Comment this macro to disable deterministic ECDSA.
   */
@@ -55,7 +55,7 @@
  
  /**
   * \def MBEDTLS_KEY_EXCHANGE_PSK_ENABLED
-@@ -768,7 +768,7 @@
+@@ -830,7 +830,7 @@
   *             See dhm.h for more details.
   *
   */
@@ -64,7 +64,7 @@
  
  /**
   * \def MBEDTLS_KEY_EXCHANGE_ECDHE_PSK_ENABLED
-@@ -788,7 +788,7 @@
+@@ -850,7 +850,7 @@
   *      MBEDTLS_TLS_ECDHE_PSK_WITH_3DES_EDE_CBC_SHA
   *      MBEDTLS_TLS_ECDHE_PSK_WITH_RC4_128_SHA
   */
@@ -73,7 +73,7 @@
  
  /**
   * \def MBEDTLS_KEY_EXCHANGE_RSA_PSK_ENABLED
-@@ -813,7 +813,7 @@
+@@ -875,7 +875,7 @@
   *      MBEDTLS_TLS_RSA_PSK_WITH_3DES_EDE_CBC_SHA
   *      MBEDTLS_TLS_RSA_PSK_WITH_RC4_128_SHA
   */
@@ -82,7 +82,7 @@
  
  /**
   * \def MBEDTLS_KEY_EXCHANGE_RSA_ENABLED
-@@ -947,7 +947,7 @@
+@@ -1009,7 +1009,7 @@
   *      MBEDTLS_TLS_ECDH_ECDSA_WITH_CAMELLIA_128_GCM_SHA256
   *      MBEDTLS_TLS_ECDH_ECDSA_WITH_CAMELLIA_256_GCM_SHA384
   */
@@ -91,7 +91,7 @@
  
  /**
   * \def MBEDTLS_KEY_EXCHANGE_ECDH_RSA_ENABLED
-@@ -971,7 +971,7 @@
+@@ -1033,7 +1033,7 @@
   *      MBEDTLS_TLS_ECDH_RSA_WITH_CAMELLIA_128_GCM_SHA256
   *      MBEDTLS_TLS_ECDH_RSA_WITH_CAMELLIA_256_GCM_SHA384
   */
  
  /**
   * \def MBEDTLS_KEY_EXCHANGE_ECJPAKE_ENABLED
-@@ -1075,7 +1075,7 @@
+@@ -1137,7 +1137,7 @@
   * This option is only useful if both MBEDTLS_SHA256_C and
   * MBEDTLS_SHA512_C are defined. Otherwise the available hash module is used.
   */
  
  /**
   * \def MBEDTLS_ENTROPY_NV_SEED
-@@ -1170,14 +1170,14 @@
+@@ -1232,14 +1232,14 @@
   * Uncomment this macro to disable the use of CRT in RSA.
   *
   */
  
  /**
   * \def MBEDTLS_SHA256_SMALLER
-@@ -1160,7 +1160,7 @@
+@@ -1255,7 +1255,7 @@
   *
   * Uncomment to enable the smaller implementation of SHA256.
   */
  
  /**
   * \def MBEDTLS_SSL_ALL_ALERT_MESSAGES
-@@ -1331,7 +1331,7 @@
+@@ -1393,7 +1393,7 @@
   *          configuration of this extension).
   *
   */
  
  /**
   * \def MBEDTLS_SSL_SRV_SUPPORT_SSLV2_CLIENT_HELLO
-@@ -1506,7 +1506,7 @@
+@@ -1568,7 +1568,7 @@
   *
   * Comment this macro to disable support for SSL session tickets
   */
  
  /**
   * \def MBEDTLS_SSL_EXPORT_KEYS
-@@ -1536,7 +1536,7 @@
+@@ -1598,7 +1598,7 @@
   *
   * Comment this macro to disable support for truncated HMAC in SSL
   */
  
  /**
   * \def MBEDTLS_SSL_TRUNCATED_HMAC_COMPAT
-@@ -1595,7 +1595,7 @@
+@@ -1657,7 +1657,7 @@
   *
   * Comment this to disable run-time checking and save ROM space
   */
  
  /**
   * \def MBEDTLS_X509_ALLOW_EXTENSIONS_NON_V3
-@@ -1925,7 +1925,7 @@
+@@ -1987,7 +1987,7 @@
   *      MBEDTLS_TLS_PSK_WITH_CAMELLIA_128_GCM_SHA256
   *      MBEDTLS_TLS_PSK_WITH_CAMELLIA_128_CBC_SHA256
   */
  
  /**
   * \def MBEDTLS_ARIA_C
-@@ -1991,7 +1991,7 @@
+@@ -2053,7 +2053,7 @@
   * This module enables the AES-CCM ciphersuites, if other requisites are
   * enabled as well.
   */
  
  /**
   * \def MBEDTLS_CERTS_C
-@@ -2003,7 +2003,7 @@
+@@ -2065,7 +2065,7 @@
   *
   * This module is used for testing (ssl_client/server).
   */
  
  /**
   * \def MBEDTLS_CHACHA20_C
-@@ -1979,7 +1979,7 @@
+@@ -2074,7 +2074,7 @@
   *
   * Module:  library/chacha20.c
   */
  
  /**
   * \def MBEDTLS_CHACHAPOLY_C
-@@ -1990,7 +1990,7 @@
+@@ -2085,7 +2085,7 @@
   *
   * This module requires: MBEDTLS_CHACHA20_C, MBEDTLS_POLY1305_C
   */
  
  /**
   * \def MBEDTLS_CIPHER_C
-@@ -2078,7 +2078,7 @@
+@@ -2140,7 +2140,7 @@
   *
   * This module provides debugging functions.
   */
  
  /**
   * \def MBEDTLS_DES_C
-@@ -2107,7 +2107,7 @@
+@@ -2169,7 +2169,7 @@
   * \warning   DES is considered a weak cipher and its use constitutes a
   *            security risk. We recommend considering stronger ciphers instead.
   */
  
  /**
   * \def MBEDTLS_DHM_C
-@@ -2270,7 +2270,7 @@
+@@ -2332,7 +2332,7 @@
   * This module adds support for the Hashed Message Authentication Code
   * (HMAC)-based key derivation function (HKDF).
   */
  
  /**
   * \def MBEDTLS_HMAC_DRBG_C
-@@ -2249,7 +2249,7 @@
+@@ -2346,7 +2346,7 @@
   *
   * Uncomment to enable the HMAC_DRBG random number geerator.
   */
  
  /**
   * \def MBEDTLS_NIST_KW_C
-@@ -2580,7 +2580,7 @@
+@@ -2642,7 +2642,7 @@
   *
   * This module enables abstraction of common (libc) functions.
   */
  
  /**
   * \def MBEDTLS_POLY1305_C
-@@ -2555,7 +2555,7 @@
+@@ -2652,7 +2652,7 @@
   * Module:  library/poly1305.c
   * Caller:  library/chachapoly.c
   */
  
  /**
   * \def MBEDTLS_RIPEMD160_C
-@@ -2601,7 +2601,7 @@
+@@ -2663,7 +2663,7 @@
   * Caller:  library/md.c
   *
   */
  
  /**
   * \def MBEDTLS_RSA_C
-@@ -2708,7 +2708,7 @@
+@@ -2770,7 +2770,7 @@
   *
   * Requires: MBEDTLS_CIPHER_C
   */
  
  /**
   * \def MBEDTLS_SSL_CLI_C
-@@ -2808,7 +2808,7 @@
+@@ -2870,7 +2870,7 @@
   *
   * This module provides run-time version information.
   */
  
  /**
   * \def MBEDTLS_X509_USE_C
-@@ -2918,7 +2918,7 @@
+@@ -2980,7 +2980,7 @@
   * Module:  library/xtea.c
   * Caller:
   */
index b6c60f0019de91a6125f4725efa3eeeda6bb8bfd..757d83f49c8f7851b74103f778d12c907837406c 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/include/mbedtls/bn_mul.h
 +++ b/include/mbedtls/bn_mul.h
-@@ -638,7 +638,8 @@
+@@ -644,7 +644,8 @@
             "r6", "r7", "r8", "r9", "cc"         \
           );
  
index 6445f5e5e03748b9d0bb275cf64a617166b7715b..5446dd8128a95dc7aa4424d672b64826e7b9b486 100644 (file)
@@ -1,19 +1,19 @@
 --- a/library/CMakeLists.txt
 +++ b/library/CMakeLists.txt
-@@ -159,7 +159,7 @@ endif(USE_STATIC_MBEDTLS_LIBRARY)
+@@ -165,7 +165,7 @@ endif(USE_STATIC_MBEDTLS_LIBRARY)
  
  if(USE_SHARED_MBEDTLS_LIBRARY)
      add_library(mbedcrypto SHARED ${src_crypto})
--    set_target_properties(mbedcrypto PROPERTIES VERSION 2.14.1 SOVERSION 3)
+-    set_target_properties(mbedcrypto PROPERTIES VERSION 2.16.1 SOVERSION 3)
 +    set_target_properties(mbedcrypto PROPERTIES VERSION 2.12.0 SOVERSION 1)
      target_link_libraries(mbedcrypto ${libs})
  
      add_library(mbedx509 SHARED ${src_x509})
-@@ -167,7 +167,7 @@ if(USE_SHARED_MBEDTLS_LIBRARY)
+@@ -173,7 +173,7 @@ if(USE_SHARED_MBEDTLS_LIBRARY)
      target_link_libraries(mbedx509 ${libs} mbedcrypto)
  
      add_library(mbedtls SHARED ${src_tls})
--    set_target_properties(mbedtls PROPERTIES VERSION 2.14.1 SOVERSION 12)
+-    set_target_properties(mbedtls PROPERTIES VERSION 2.16.1 SOVERSION 12)
 +    set_target_properties(mbedtls PROPERTIES VERSION 2.12.0 SOVERSION 10)
      target_link_libraries(mbedtls ${libs} mbedx509)