tools/squashfs4: enable parallel builds
authorLinhui Liu <liulinhui36@gmail.com>
Fri, 31 Mar 2023 13:34:01 +0000 (21:34 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 1 Apr 2023 19:58:31 +0000 (21:58 +0200)
Run `time make tools/squashfs4/{clean,compile} -j$(nproc)`
Before:
real    0m8.803s
user    0m12.415s
sys     0m1.317s
After:
real    0m13.781s
user    0m13.290s
sys     0m1.528s

Signed-off-by: Linhui Liu <liulinhui36@gmail.com>
tools/squashfs4/Makefile

index 7c8bcf1a72e959b3758f757c9ba7e793601ee9df..bcbe98e0ddca62df624f9acfc8028f6aafff27a1 100644 (file)
@@ -17,11 +17,13 @@ PKG_SOURCE_DATE:=2022-03-17
 PKG_SOURCE_VERSION:=afdd63fc386919b4aa40d573b0a6069414d14317
 PKG_MIRROR_HASH:=59c294e00ddfc1f4bda658c7567584ce35fdd479c413ebdb1376981b27737be1
 
+HOST_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        +$(HOST_MAKE_VARS) \
-       $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+       $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/squashfs-tools \
                XZ_SUPPORT=1 \
                LZMA_XZ_SUPPORT=1 \
                EXTRA_CFLAGS="-I$(STAGING_DIR_HOST)/include" \