target/x86: add grub2-bios-setup to DEFAULT_PACKAGES
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 11 Aug 2021 09:58:45 +0000 (11:58 +0200)
committerPaul Spooren <mail@aparcar.org>
Mon, 19 Sep 2022 17:30:15 +0000 (19:30 +0200)
With the commit 5876d6a62fc0ae5799e7d9c896356f75c99a6f0a the command under
`/usr/sbin/grub-bios-setup` has been moved to its own package named
`grub-bios-setup`.

The script `81_upgrade_bootloader` under `/lib/preinit` is used by all
x86 targets to update the bootloader. The script is using the command
`grub-bios-setup` for this.

I get the following output at the first boot after the upgrade.
`/etc/preinit: line 9: /usr/sbin/grub-bios-setup: not found`.

To fix this, the DEFAULT_PACKAGES dependency is extended by the entry
`grub2-bios-setup` so that the missing command is installed again.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
target/linux/x86/Makefile

index 880ac73df8c6694ec720746678172744c19fe73d..20539e5ed3f6daf33d80f3df49b9b99d654d59ae 100644 (file)
@@ -17,7 +17,10 @@ KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs kmod-button-hotplug
+DEFAULT_PACKAGES += \
+       partx-utils mkf2fs \
+       e2fsprogs kmod-button-hotplug \
+       grub2-bios-setup
 
 $(eval $(call BuildTarget))