kernel: bump 4.14 to 4.14.96
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 28 Jan 2019 09:49:44 +0000 (10:49 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 31 Jan 2019 14:35:22 +0000 (15:35 +0100)
Refreshed all patches.

New symbol added:
- CONFIG_CIFS_ALLOW_INSECURE_LEGACY

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
15 files changed:
include/kernel-version.mk
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/backport-4.14/336-v4.15-netfilter-exit_net-cleanup-check-added.patch
target/linux/generic/backport-4.14/420-enable-CONFIG_MMC_SDHCI_IO_ACCESSORS.patch
target/linux/generic/config-4.14
target/linux/generic/hack-4.14/301-mips_image_cmdline_hack.patch
target/linux/generic/hack-4.14/901-debloat_sock_diag.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/300-mips_expose_boot_raw.patch
target/linux/generic/pending-4.14/304-mips_disable_fpu.patch
target/linux/generic/pending-4.14/341-MIPS-mm-remove-no-op-dma_map_ops-where-possible.patch
target/linux/generic/pending-4.14/530-jffs2_make_lzma_available.patch
target/linux/lantiq/patches-4.14/0152-lantiq-VPE.patch
target/linux/ramips/patches-4.14/0046-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch
target/linux/ramips/patches-4.14/0051-serial-add-ugly-custom-baud-rate-hack.patch

index dcbffc542258bb82389b4267e6016ad59054b563..be794183fa06d0a2ca1666f5f354311c3c311771 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.14 = .95
 LINUX_VERSION-4.9 = .153
+LINUX_VERSION-4.14 = .96
 
-LINUX_KERNEL_HASH-4.14.95 = ce6729e3fca312520e3cb4f27993852dbb019d94c59c0b35cedab571f9cb58e4
 LINUX_KERNEL_HASH-4.9.153 = 9066929ec2550794ae107350a5f3c5b648438aa915cfc62bac5b7a54b9d7731a
+LINUX_KERNEL_HASH-4.14.96 = 110daeae1a416b7e0ec8dce5e86d67552deeb4567f696c3869389be239f0ecb5
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 5639497926cb0d8e558a95527a3f481fd05d8d01..915a7f05d16315610eb7fc0fddad58e5c73c20c4 100644 (file)
@@ -55,7 +55,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
        rwlock_t                sk_callback_lock;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2742,6 +2742,7 @@ void sock_init_data(struct socket *sock,
+@@ -2743,6 +2743,7 @@ void sock_init_data(struct socket *sock,
  
        sk->sk_max_pacing_rate = ~0U;
        sk->sk_pacing_rate = ~0U;
index e20ddc2917a61330dda6498a58bffcc298a81427..844ba450d7455c87e72ca7e7346eb15ad658e988 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
 
 --- a/net/ipv4/netfilter/ipt_CLUSTERIP.c
 +++ b/net/ipv4/netfilter/ipt_CLUSTERIP.c
-@@ -834,6 +834,7 @@ static void clusterip_net_exit(struct ne
+@@ -835,6 +835,7 @@ static void clusterip_net_exit(struct ne
        cn->procdir = NULL;
  #endif
        nf_unregister_net_hook(net, &cip_arp_ops);
index 994ecd7ed4197c2d7bf93a621ba6807d56c43cb3..744cf4cff26bbaf77b427bf178c4de1a89dc63be 100644 (file)
@@ -13,7 +13,7 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
 
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -420,6 +420,7 @@ config MMC_SDHCI_MSM
+@@ -429,6 +429,7 @@ config MMC_SDHCI_MSM
        tristate "Qualcomm SDHCI Controller Support"
        depends on ARCH_QCOM || (ARM && COMPILE_TEST)
        depends on MMC_SDHCI_PLTFM
index 34773958f5ef2955ac6360d9c9909cb7db532129..ea5aeed90a4d76d3249c31098d5bf997983f8372 100644 (file)
@@ -763,6 +763,7 @@ CONFIG_CC_STACKPROTECTOR_NONE=y
 # CONFIG_CICADA_PHY is not set
 # CONFIG_CIFS is not set
 # CONFIG_CIFS_ACL is not set
+CONFIG_CIFS_ALLOW_INSECURE_LEGACY=y
 # CONFIG_CIFS_DEBUG is not set
 # CONFIG_CIFS_DEBUG2 is not set
 # CONFIG_CIFS_FSCACHE is not set
index eb6011e813da60183877379b5c08c622c5cf5fa6..bc49e5b40e3829ae13a391ddd0a0ea9af5495ed7 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1158,6 +1158,10 @@ config SYNC_R4K
+@@ -1161,6 +1161,10 @@ config SYNC_R4K
  config MIPS_MACHINE
        def_bool n
  
index d250843a6a26397bde4d44dfc3f6c008e5c65df2..36d69c1dfde9e1d703369e2ff5f690de29f719eb 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  struct dst_entry *__sk_dst_check(struct sock *sk, u32 cookie)
  {
        struct dst_entry *dst = __sk_dst_get(sk);
-@@ -1595,9 +1607,11 @@ void sk_destruct(struct sock *sk)
+@@ -1596,9 +1608,11 @@ void sk_destruct(struct sock *sk)
  
  static void __sk_free(struct sock *sk)
  {
index 1121ac1181674962a7f2451c03beaae156806fab..d7b681942ef83be46d763e804a080872ffba062a 100644 (file)
@@ -328,7 +328,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3381,6 +3381,8 @@ static __net_initdata struct pernet_oper
+@@ -3382,6 +3382,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
index 5384be15ca02e4c77c2f762d00626c2454b8d613..35854f323ca3ae7012d680580985f2e9bf98a11c 100644 (file)
@@ -9,7 +9,7 @@ Acked-by: Rob Landley <rob@landley.net>
 ---
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1067,9 +1067,6 @@ config FW_ARC
+@@ -1070,9 +1070,6 @@ config FW_ARC
  config ARCH_MAY_HAVE_PC_FDC
        bool
  
@@ -19,7 +19,7 @@ Acked-by: Rob Landley <rob@landley.net>
  config CEVT_BCM1480
        bool
  
-@@ -2967,6 +2964,18 @@ choice
+@@ -2970,6 +2967,18 @@ choice
                bool "Extend builtin kernel arguments with bootloader arguments"
  endchoice
  
index 22e2e86206c191275c38ccba6dd922a1f75779aa..57827d5aa51be566208d820aa75078a1e988a2fc 100644 (file)
@@ -24,7 +24,7 @@ v2: incorporated changes suggested by Jonas Gorski
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2891,6 +2891,20 @@ config MIPS_O32_FP64_SUPPORT
+@@ -2894,6 +2894,20 @@ config MIPS_O32_FP64_SUPPORT
  
          If unsure, say N.
  
index de2dd65b1795c7f74021fe5eac61363d51755ec5..2c78b91c57bc1a072c0bfd903ed79a0865f2f030 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        select HAVE_PCSPKR_PLATFORM
        select IRQ_MIPS_CPU
        select I8253
-@@ -1128,6 +1130,9 @@ config DMA_NONCOHERENT
+@@ -1131,6 +1133,9 @@ config DMA_NONCOHERENT
        bool
        select NEED_DMA_MAP_STATE
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config NEED_DMA_MAP_STATE
        bool
  
-@@ -1652,6 +1657,7 @@ config CPU_R10000
+@@ -1655,6 +1660,7 @@ config CPU_R10000
        select CPU_SUPPORTS_64BIT_KERNEL
        select CPU_SUPPORTS_HIGHMEM
        select CPU_SUPPORTS_HUGEPAGES
@@ -48,7 +48,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        help
          MIPS Technologies R10000-series processors.
  
-@@ -1900,9 +1906,11 @@ config SYS_HAS_CPU_MIPS32_R3_5
+@@ -1903,9 +1909,11 @@ config SYS_HAS_CPU_MIPS32_R3_5
        bool
  
  config SYS_HAS_CPU_MIPS32_R5
@@ -60,7 +60,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        bool
  
  config SYS_HAS_CPU_MIPS64_R1
-@@ -1912,6 +1920,7 @@ config SYS_HAS_CPU_MIPS64_R2
+@@ -1915,6 +1923,7 @@ config SYS_HAS_CPU_MIPS64_R2
        bool
  
  config SYS_HAS_CPU_MIPS64_R6
index 4e1dfbe7766754728634be603cc781201cce520b..834876fa84c2e433b2edc5693a2bc50b76f6532e 100644 (file)
@@ -244,7 +244,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
 +}
 --- a/fs/jffs2/super.c
 +++ b/fs/jffs2/super.c
-@@ -370,14 +370,41 @@ static int __init init_jffs2_fs(void)
+@@ -371,14 +371,41 @@ static int __init init_jffs2_fs(void)
        BUILD_BUG_ON(sizeof(struct jffs2_raw_inode) != 68);
        BUILD_BUG_ON(sizeof(struct jffs2_raw_summary) != 32);
  
index fc4e414df5aea1bb57c2e810bd9a0491c8a4aae2..b0b5bd3a57e30d6bfbdb91a71629db561636f5fc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2324,6 +2324,12 @@ config MIPS_VPE_LOADER
+@@ -2327,6 +2327,12 @@ config MIPS_VPE_LOADER
          Includes a loader for loading an elf relocatable object
          onto another VPE and running it.
  
index 353b6836af48cc2311c52f8a01fe3eccf29d0c90..4c4147ef52fcbc8fc0194b11d9e85db16c16b002 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -899,3 +899,5 @@ config MMC_SDHCI_XENON
+@@ -900,3 +900,5 @@ config MMC_SDHCI_XENON
          This selects Marvell Xenon eMMC/SD/SDIO SDHCI.
          If you have a controller with this interface, say Y or M here.
          If unsure, say N.
index 634033d18d3fe5862d94037dca524a5d75e68b06..2ad1f6f9f8c5c022226b12afd4e752a0fad8908e 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/tty/serial/serial_core.c
 +++ b/drivers/tty/serial/serial_core.c
-@@ -418,6 +418,9 @@ uart_get_baud_rate(struct uart_port *por
+@@ -428,6 +428,9 @@ uart_get_baud_rate(struct uart_port *por
                break;
        }