arm-trusted-firmware-mvebu: don't build emmc variants
authorAndre Heider <a.heider@gmail.com>
Sun, 17 Jan 2021 07:38:22 +0000 (08:38 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 30 Jan 2021 13:46:32 +0000 (14:46 +0100)
Starting with u-boot v2021.01 a single binary will be used for non-emmc
and emmc variants.

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/boot/arm-trusted-firmware-mvebu/Makefile

index 1f84b8eb19293056799a4e0ecbfd15611402474f..7778a261586e8cdd57cf5df793e7318a16f2d1ce 100644 (file)
@@ -46,16 +46,6 @@ define Trusted-Firmware-A/espressobin-v3-v5-1gb-1cs
   PLAT:=a3700
 endef
 
-define Trusted-Firmware-A/espressobin-v3-v5-1gb-1cs-emmc
-  NAME:=Marvell ESPRESSObin V3-V5 (1GB 1CS, eMMC)
-  DEPENDS:=+u-boot-espressobin-emmc
-  BUILD_DEVICES:=globalscale_espressobin-emmc
-  UBOOT:=espressobin-emmc
-  DDR_TOPOLOGY:=4
-  CLOCKSPRESET:=CPU_800_DDR_800
-  PLAT:=a3700
-endef
-
 define Trusted-Firmware-A/espressobin-v3-v5-1gb-2cs
   NAME:=Marvell ESPRESSObin V3-V5 (1GB, 2CS)
   DEPENDS:=+u-boot-espressobin
@@ -66,16 +56,6 @@ define Trusted-Firmware-A/espressobin-v3-v5-1gb-2cs
   PLAT:=a3700
 endef
 
-define Trusted-Firmware-A/espressobin-v3-v5-1gb-2cs-emmc
-  NAME:=Marvell ESPRESSObin V3-V5 (1GB 2CS, eMMC)
-  DEPENDS:=+u-boot-espressobin-emmc
-  BUILD_DEVICES:=globalscale_espressobin-emmc
-  UBOOT:=espressobin-emmc
-  DDR_TOPOLOGY:=2
-  CLOCKSPRESET:=CPU_800_DDR_800
-  PLAT:=a3700
-endef
-
 define Trusted-Firmware-A/espressobin-v3-v5-2gb
   NAME:=Marvell ESPRESSObin V3-V5 (2GB)
   DEPENDS:=+u-boot-espressobin
@@ -86,16 +66,6 @@ define Trusted-Firmware-A/espressobin-v3-v5-2gb
   PLAT:=a3700
 endef
 
-define Trusted-Firmware-A/espressobin-v3-v5-2gb-emmc
-  NAME:=Marvell ESPRESSObin V3-V5 (2GB, eMMC)
-  DEPENDS:=+u-boot-espressobin-emmc
-  BUILD_DEVICES:=globalscale_espressobin-emmc
-  UBOOT:=espressobin-emmc
-  DDR_TOPOLOGY:=7
-  CLOCKSPRESET:=CPU_800_DDR_800
-  PLAT:=a3700
-endef
-
 define Trusted-Firmware-A/espressobin-v7-1gb
   NAME:=Marvell ESPRESSObin V7 (1GB)
   DEPENDS:=+u-boot-espressobin
@@ -106,16 +76,6 @@ define Trusted-Firmware-A/espressobin-v7-1gb
   PLAT:=a3700
 endef
 
-define Trusted-Firmware-A/espressobin-v7-1gb-emmc
-  NAME:=Marvell ESPRESSObin V7 (1GB, eMMC)
-  DEPENDS:=+u-boot-espressobin
-  BUILD_DEVICES:=globalscale_espressobin-v7-emmc
-  UBOOT:=espressobin-emmc
-  DDR_TOPOLOGY:=5
-  CLOCKSPRESET:=CPU_800_DDR_800
-  PLAT:=a3700
-endef
-
 define Trusted-Firmware-A/espressobin-v7-2gb
   NAME:=Marvell ESPRESSObin V7 (2GB)
   DEPENDS:=+u-boot-espressobin
@@ -126,16 +86,6 @@ define Trusted-Firmware-A/espressobin-v7-2gb
   PLAT:=a3700
 endef
 
-define Trusted-Firmware-A/espressobin-v7-2gb-emmc
-  NAME:=Marvell ESPRESSObin V7 (2GB, eMMC)
-  DEPENDS:=+u-boot-espressobin
-  BUILD_DEVICES:=globalscale_espressobin-v7-emmc
-  UBOOT:=espressobin-emmc
-  DDR_TOPOLOGY:=6
-  CLOCKSPRESET:=CPU_800_DDR_800
-  PLAT:=a3700
-endef
-
 define Trusted-Firmware-A/udpu
   NAME:=Methode uDPU
   DEPENDS:=+u-boot-uDPU
@@ -150,15 +100,10 @@ endef
 TFA_TARGETS:= \
        espressobin-512mb \
        espressobin-v3-v5-1gb-1cs \
-       espressobin-v3-v5-1gb-1cs-emmc \
        espressobin-v3-v5-1gb-2cs \
-       espressobin-v3-v5-1gb-2cs-emmc \
        espressobin-v3-v5-2gb \
-       espressobin-v3-v5-2gb-emmc \
        espressobin-v7-1gb \
-       espressobin-v7-1gb-emmc \
        espressobin-v7-2gb \
-       espressobin-v7-2gb-emmc \
        udpu
 
 TFA_MAKE_FLAGS += \