mpc85xx: fix incorrect kernel target
authorDavid Bauer <mail@david-bauer.net>
Sun, 19 Mar 2023 20:33:32 +0000 (21:33 +0100)
committerDavid Bauer <mail@david-bauer.net>
Mon, 20 Mar 2023 02:10:43 +0000 (03:10 +0100)
The wrapper-image for the WL-WDR4900 was used as a build-target for the
kernel. This workd fine as long as only a single wrapper is used with
the OpenWrt build-system.

If additional wrappers are used, the build becomes racy in the
wrapper-stage.

The wrapper images actually do not represent a target. They are built
based on the kernel configuration. Only copy the resulting images to
avoid race-conditions as explained.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/mpc85xx/p1010/target.mk

index 019536ff1ab3944835c1ca6100dc3085b2cdc423..86628e32dacbb54da7d73c5985248318b1d2e8e4 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME:=P1010
-KERNELNAME:=simpleImage.tl-wdr4900-v1
+KERNEL_IMAGES:=simpleImage.tl-wdr4900-v1
 
 define Target/Description
        Build firmware images for P1010 based boards.