linux-firmware: add Raspberry Pi 5 NVRAM
authorMarty Jones <mj8263788@gmail.com>
Tue, 7 Nov 2023 03:21:44 +0000 (22:21 -0500)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 25 Jan 2024 16:46:46 +0000 (17:46 +0100)
The RPi 5 expects the same NVRAM as the one from RPi 4 on a different file.

Signed-off-by: Marty Jones <mj8263788@gmail.com>
[Reword commit description, add missing PKG_RELEASE bump]
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
package/firmware/linux-firmware/Makefile
package/firmware/linux-firmware/broadcom.mk

index 79341c30cb4a68394334a50e2787a4758ab5a0f9..f7f1f978e30bed04fc747ab7539024ee2995159e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linux-firmware
 PKG_VERSION:=20231211
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/firmware
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
index 4f64b423eb8758a1fadc54d1d78abc1a9fb683b8..088a2665ccd6465ab456c7e8d172e2851513e76d 100644 (file)
@@ -125,9 +125,15 @@ define Package/brcmfmac-nvram-43455-sdio/install
        $(LN) \
                brcmfmac43455-sdio.raspberrypi,4-model-b.txt \
                $(1)/lib/firmware/brcm/brcmfmac43455-sdio.Raspberry\ Pi\ Foundation-Raspberry\ Pi\ 4\ Model\ B.txt
+       $(LN) \
+               brcmfmac43455-sdio.raspberrypi,4-model-b.txt \
+               $(1)/lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,5-model-b.txt
        $(LN) \
                brcmfmac43455-sdio.raspberrypi,4-model-b.txt \
                $(1)/lib/firmware/brcm/brcmfmac43455-sdio.Raspberry\ Pi\ Foundation-Raspberry\ Pi\ Compute\ Module\ 4.txt
+       $(LN) \
+               brcmfmac43455-sdio.raspberrypi,4-model-b.txt \
+               $(1)/lib/firmware/brcm/brcmfmac43455-sdio.Raspberry\ Pi\ Foundation-Raspberry\ Pi\ 5\ Model\ B.txt
        $(INSTALL_DATA) \
                $(PKG_BUILD_DIR)/brcm/brcmfmac43455-sdio.MINIX-NEO\ Z83-4.txt \
                $(1)/lib/firmware/brcm/