iptables: make iptables-mod-conntrack-extra depend on kmod-ipt-raw
authorJo-Philipp Wich <jo@mein.io>
Wed, 22 Aug 2018 05:12:47 +0000 (07:12 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 22 Aug 2018 05:14:45 +0000 (07:14 +0200)
Since kernel 4.14 there is no auto assignment of conntrack helpers anymore
so fw3 needs raw table support in order to stage ct helper assignment rules.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/utils/iptables/Makefile

index 9bcb864b9744e943695ea2237712823a1d1ffb42..4c5a581268efd9513f86702558852007af78a1a8 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.6.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.netfilter.org/iptables
@@ -122,7 +122,7 @@ Extra iptables nftables compat binaries.
 endef
 
 define Package/iptables-mod-conntrack-extra
-$(call Package/iptables/Module, +kmod-ipt-conntrack-extra)
+$(call Package/iptables/Module, +kmod-ipt-conntrack-extra +kmod-ipt-raw)
   TITLE:=Extra connection tracking extensions
 endef