tegra: image: make bootscript standalone
authorTomasz Maciej Nowak <tmn505@gmail.com>
Wed, 25 Nov 2020 16:10:04 +0000 (17:10 +0100)
committerPetr Štetiar <ynezz@true.cz>
Tue, 22 Dec 2020 17:59:10 +0000 (18:59 +0100)
Don't hard-code the PTUUID, use U-Boot commands to determine it, as some
partitioning tools could rewrite PTUUID when modifying partitions.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
target/linux/tegra/image/Makefile
target/linux/tegra/image/generic-bootscript

index aa0083f9ae475bf27c6698041304251a9473bcf0..fbff1cf6e8749899eb1a9d9935de991c3af094f0 100644 (file)
@@ -14,10 +14,7 @@ define Build/tegra-sdcard
        $(if $(DEVICE_DTS),\
                $(foreach dtb,$(DEVICE_DTS),$(CP) $(DTS_DIR)/$(dtb).dtb $@.boot), \
                $(CP) $(DTS_DIR)/*.dtb $@.boot)
-       sed \
-               -e 's#@ROOT@#$(IMG_PART_SIGNATURE)#g' \
-               -e 's#@KERNEL@#$(KERNEL_NAME)#g' \
-               $(BOOT_SCRIPT) > $@-boot.scr
+       sed -e 's#@KERNEL@#$(KERNEL_NAME)#g' $(BOOT_SCRIPT) > $@-boot.scr
        mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
                -n '$(DEVICE_TITLE) OpenWrt bootscript' \
                -d $@-boot.scr \
index 7e86afdf5fb5db16eb3225da275e23e7036d7d73..0908025d5d59f4156a3d3d1bd22194fb267a4d2b 100644 (file)
@@ -1,4 +1,6 @@
-setenv bootargs "root=PARTUUID=@ROOT@-02 rw rootwait console=ttyS0,115200 console=tty0"
+part uuid ${devtype} ${devnum}:2 ptuuid
+
+setenv bootargs "root=PARTUUID=${ptuuid} rw rootwait console=ttyS0,115200 console=tty0"
 
 load ${devtype} ${devnum}:${bootpart} ${kernel_addr_r} /@KERNEL@
 load ${devtype} ${devnum}:${bootpart} ${fdt_addr_r} /${soc}-${board}.dtb