wireguard: bump to 0.0.20180513
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sun, 13 May 2018 19:05:15 +0000 (20:05 +0100)
committerYousong Zhou <yszhou4tech@gmail.com>
Mon, 14 May 2018 02:41:21 +0000 (10:41 +0800)
6b4a340 version: bump snapshot
faa2103 compat: don't clear header bits on RHEL
4014532 compat: handle RHEL 7.5's recent backports
66589bc queueing: preserve pfmemalloc header bit
37f114a chacha20poly1305: make gcc 8.1 happy
926caae socket: use skb_put_data
724d979 wg-quick: preliminary support for go implementation
c454c26 allowedips: simplify arithmetic
71d44be allowedips: produce better assembly with unsigned arithmetic
5e3532e allowedips: use native endian on lookup
856f105 allowedips: add selftest for allowedips_walk_by_peer
41df6d2 embeddable-wg-library: zero attribute padding
9a1bea6 keygen-html: add zip file example
f182b1a qemu: retry on 404 in wget for kernel.org race

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/services/wireguard/Makefile

index 9ed24ecaa3531518a73271ed10f955f6d21a71a3..1aa8659124a1cf7d119af33d829b30d046b7dfc1 100644 (file)
@@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=wireguard
 
-PKG_VERSION:=0.0.20180420
+PKG_VERSION:=0.0.20180513
 PKG_RELEASE:=1
 
 PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
-PKG_HASH:=b58cd2acf9e8d3fe9044c06c0056bd74da1f5673a456f011d36eee3f6fb1da16
+PKG_HASH:=28a15c59f6710851587ebca76a335f1aaaa077aad052732e0959f2bae9ba8d5c
 
 PKG_LICENSE:=GPL-2.0 Apache-2.0
 PKG_LICENSE_FILES:=COPYING