kmod-tcp-bbr: leave CONFIG_TCP_CONG_ADVANCED to target config
authorYousong Zhou <yszhou4tech@gmail.com>
Thu, 24 Dec 2020 01:41:56 +0000 (09:41 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Sat, 26 Dec 2020 02:08:08 +0000 (10:08 +0800)
Since generic has the option set to y and other targets now inherit that
choice, there is no behaviour change

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
package/kernel/linux/modules/netsupport.mk

index 0c68b394d1e20462fcb86acffd6d4802bc91c1d3..958b510015e834dfdd288d3389354e7007ca1ee9 100644 (file)
@@ -926,9 +926,7 @@ $(eval $(call KernelPackage,sched))
 define KernelPackage/tcp-bbr
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=BBR TCP congestion control
-  KCONFIG:= \
-       CONFIG_TCP_CONG_ADVANCED=y \
-       CONFIG_TCP_CONG_BBR
+  KCONFIG:=CONFIG_TCP_CONG_BBR
   FILES:=$(LINUX_DIR)/net/ipv4/tcp_bbr.ko
   AUTOLOAD:=$(call AutoLoad,74,tcp_bbr)
 endef