ath79: add support for Senao Engenius EAP600
authorMichael Pratt <mcpratt@pm.me>
Fri, 9 Oct 2020 16:28:11 +0000 (12:28 -0400)
committerPetr Štetiar <ynezz@true.cz>
Fri, 25 Dec 2020 09:38:13 +0000 (10:38 +0100)
FCC ID: A8J-EAP600

Engenius EAP600 is a wireless access point with 1 gigabit ethernet port,
dual-band wireless, external ethernet switch, 4 internal antennas
and 802.3af PoE.

Specification:

  - AR9344 SOC (5 GHz, 2x2, WMAC)
  - AR9382 WLAN (2.4 GHz, 2x2, PCIe on-board)
  - AR8035-A switch (GbE with 802.3af PoE)
  - 40 MHz reference clock
  - 16 MB FLASH MX25L12845EMI-10G
  - 2x 64 MB RAM NT5TU32M16DG
  - UART at H1 (populated)
  - 5 LEDs, 1 button (power, eth, 2.4 GHz, 5 GHz, wps) (reset)
  - 4 internal antennas

MAC addresses:

  MAC addresses are labeled MAC1 and MAC2
  The MAC address in flash is not on the label
  The OEM software reports these MACs for the ifconfig

  eth0 MAC 1 *:5e ---
  phy1 MAC 2 *:5f --- (2.4 GHz)
  phy0 ----- *:60 art 0x0 (5 GHz)

Installation:

  2 ways to flash factory.bin from OEM:

  - if you get Failsafe Mode from failed flash:
      only use it to flash Original firmware from Engenius
      or risk kernel loop or halt which requires serial cable

  Method 1: Firmware upgrade page:

    OEM webpage at 192.168.1.1
    username and password "admin"
    Navigate to "Upgrade Firmware" page from left pane
    Click Browse and select the factory.bin image
    Upload and verify checksum
    Click Continue to confirm and wait 3 minutes

  Method 2: Serial to load Failsafe webpage:

    After connecting to serial console and rebooting...
    Interrupt uboot with any key pressed rapidly
    execute `run failsafe_boot` OR `bootm 0x9fdf0000`
    wait a minute
    connect to ethernet and navigate to
    "192.168.1.1/index.htm"
    Select the factory.bin image and upload
    wait about 3 minutes

Return to OEM:

  If you have a serial cable, see Serial Failsafe instructions
  otherwise, uboot-env can be used to make uboot load the failsafe image

  *DISCLAIMER*
  The Failsafe image is unique to Engenius boards.
  If the failsafe image is missing or damaged this will not work
  DO NOT downgrade to ar71xx this way, it can cause kernel loop or halt

  ssh into openwrt and run
  `fw_setenv rootfs_checksum 0`
  reboot, wait 3 minutes
  connect to ethernet and navigate to 192.168.1.1/index.htm
  select OEM firmware image from Engenius and click upgrade

Format of OEM firmware image:

  The OEM software of EAP600 is a heavily modified version
  of Openwrt Kamikaze. One of the many modifications
  is to the sysupgrade program. Image verification is performed
  simply by the successful ungzip and untar of the supplied file
  and name check and header verification of the resulting contents.
  To form a factory.bin that is accepted by OEM Openwrt build,
  the kernel and rootfs must have specific names...

    openwrt-senao-eap600-uImage-lzma.bin
    openwrt-senao-eap600-root.squashfs

  and begin with the respective headers (uImage, squashfs).
  Then the files must be tarballed and gzipped.
  The resulting binary is actually a tar.gz file in disguise.
  This can be verified by using binwalk on the OEM firmware images,
  ungzipping then untaring.

  The OEM upgrade script is at /etc/fwupgrade.sh

  Later models in the EAP series likely have a different platform
  and the upgrade and image verification process differs.

  OKLI kernel loader is required because the OEM software
  expects the kernel to be no greater than 1536k
  and the factory.bin upgrade procedure would
  overwrite part of the kernel when writing rootfs.

Note on PLL-data cells:

  The default PLL register values will not work
  because of the external AR8035-A switch between
  the SOC and the ethernet PHY chips.

  For AR934x series, the PLL register for GMAC0
  can be seen in the DTSI as 0x2c.
  Therefore the PLL register can be read from uboot
  for each link speed after attempting tftpboot
  or another network action using that link speed
  with `md 0x1805002c 1`.

  Unfortunately uboot did not have the best values
  so they were taken from other similar DTS files.

Tested from master, all link speeds functional

Signed-off-by: Michael Pratt <mcpratt@pm.me>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/ar9344_engenius_eap600.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/image/generic.mk

index 4cfcdd3066c30e48da3064e83e01af3844512940..8f4b8ef31eacd59a3fc1c41e4eddc80fe359d484 100644 (file)
@@ -24,6 +24,7 @@ arduino,yun|\
 buffalo,bhr-4grv2|\
 devolo,magic-2-wifi|\
 engenius,eap300-v2|\
+engenius,eap600|\
 engenius,ecb1200|\
 engenius,ecb1750|\
 engenius,ecb350-v1|\
diff --git a/target/linux/ath79/dts/ar9344_engenius_eap600.dts b/target/linux/ath79/dts/ar9344_engenius_eap600.dts
new file mode 100644 (file)
index 0000000..c6961f6
--- /dev/null
@@ -0,0 +1,45 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9344_engenius_exx600.dtsi"
+
+/ {
+       model = "EnGenius EAP600";
+       compatible = "engenius,eap600", "qca,ar9344";
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       label = "amber:power";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wps {
+                       label = "blue:wps";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi5g {
+                       label = "green:wifi5g";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+};
+
+&eth0 {
+       mtd-mac-address = <&art 0x0>;
+       mtd-mac-address-increment = <(-2)>;
+};
+
+&pcie {
+       wifi@0,0,0 {
+               mtd-mac-address = <&art 0x0>;
+       };
+};
+
+&wmac {
+       mtd-mac-address = <&art 0x0>;
+       mtd-mac-address-increment = <(-1)>;
+};
index a3b5d45ad26c3ed8cf7cd28217f870870a823f18..355ea25b4d2ed3e324092ba286bfe122d2c69358 100755 (executable)
@@ -29,6 +29,7 @@ ath79_setup_interfaces()
        dlink,dap-1365-a1|\
        dlink,dir-505|\
        engenius,eap300-v2|\
+       engenius,eap600|\
        engenius,ecb1200|\
        engenius,ecb1750|\
        engenius,ecb350-v1|\
index 867a1dac4447baf95d82616171032a7ed20d3075..553db59231018e038248129298a23ec0aee9ef0d 100644 (file)
@@ -88,6 +88,7 @@ case "$FIRMWARE" in
                caldata_extract "art" 0x5000 0x440
                ath9k_patch_mac $(macaddr_add $(mtd_get_mac_text "mac" 0x18) 1)
                ;;
+       engenius,eap600|\
        engenius,ecb600|\
        mercury,mw4530r-v1|\
        ocedo,raccoon|\
index 064177fcaf52f27b898195415515632294b9aa08..8f9e7159d1caece76bd6ed5dfc5e5831b1c91ad7 100644 (file)
@@ -965,6 +965,16 @@ define Device/engenius_eap300-v2
 endef
 TARGET_DEVICES += engenius_eap300-v2
 
+define Device/engenius_eap600
+  $(Device/engenius_loader_okli)
+  SOC := ar9344
+  DEVICE_MODEL := EAP600
+  IMAGE_SIZE := 12032k
+  LOADER_FLASH_OFFS := 0x230000
+  ENGENIUS_IMGNAME := senao-eap600
+endef
+TARGET_DEVICES += engenius_eap600
+
 define Device/engenius_ecb1200
   SOC := qca9557
   DEVICE_VENDOR := EnGenius