ramips: enable MT7610E 5GHz radio of MT7620a_MT7610e EVB
authorDeng Qingfang <dengqf6@mail2.sysu.edu.cn>
Wed, 9 Jan 2019 12:54:34 +0000 (20:54 +0800)
committerChristian Lamparter <chunkeey@gmail.com>
Tue, 5 Feb 2019 18:37:30 +0000 (19:37 +0100)
This enables MT7610E of the EVB

Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
target/linux/ramips/dts/MT7620a_MT7610e.dts
target/linux/ramips/image/mt7620.mk

index f90ba851be6ad7aa221f4e2603e29e0636d51c35..e0ae57a0d95508b2c3446c36c070df3ac6c2df8e 100644 (file)
 &pcie {
        status = "okay";
 };
+
+&pcie0 {
+       wifi@0,0 {
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
index e487f529d6daf417434f73192213652f9bb1a918..57903232edc2cd395d13c3d32c3cca48e8308b89 100644 (file)
@@ -431,6 +431,7 @@ TARGET_DEVICES += mt7620a_mt7530
 define Device/mt7620a_mt7610e
   DTS := MT7620a_MT7610e
   DEVICE_TITLE := MediaTek MT7620a + MT7610e EVB
+  DEVICE_PACKAGES := kmod-mt76x0e
   SUPPORTED_DEVICES := mt7620a_mt7610e
 endef
 TARGET_DEVICES += mt7620a_mt7610e