conntrack-tools: relocated to packages feed
authorJo-Philipp Wich <jo@mein.io>
Tue, 22 Jan 2019 07:14:00 +0000 (08:14 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 22 Jan 2019 07:14:00 +0000 (08:14 +0100)
In order to prepare the switch from librpc to libtirpc, we need to relocate
conntrack-tools to the packages feed.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/utils/conntrack-tools/Makefile [deleted file]
package/network/utils/conntrack-tools/files/conntrackd.init [deleted file]

diff --git a/package/network/utils/conntrack-tools/Makefile b/package/network/utils/conntrack-tools/Makefile
deleted file mode 100644 (file)
index f04ac69..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-#
-# Copyright (C) 2009-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=conntrack-tools
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://git.netfilter.org/conntrack-tools
-PKG_SOURCE_DATE:=2017-09-27
-PKG_SOURCE_VERSION:=eefe649ca51ed0cbb995454cdc366f5072f6443c
-PKG_MIRROR_HASH:=1c207c3e423d741fbb31e3c29486a811e6dad493f26ec47a2df75b6262a1b4bd
-
-PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-PKG_LICENSE:=GPL-2.0
-PKG_CPE_ID:=cpe:/a:conntrack-tools_project:conntrack-tools
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-PKG_BUILD_DEPENDS:=librpc
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/conntrack-tools/default
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libnetfilter-conntrack +libnetfilter-cttimeout +libnetfilter-cthelper +libnetfilter-queue
-  SUBMENU:=Firewall
-  URL:=http://conntrack-tools.netfilter.org/
-endef
-
-define Package/conntrack
-$(call Package/conntrack-tools/default)
-  TITLE:=Connection tracking tool
-endef
-
-define Package/conntrack/description
- Conntrack is a userspace command line program targeted at system
- administrators. It enables them to view and manage the in-kernel
- connection tracking state table.
-endef
-
-define Package/conntrack/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/conntrack $(1)/usr/sbin/
-endef
-
-define Package/conntrackd
-$(call Package/conntrack-tools/default)
-  TITLE:=Connection tracking daemon
-endef
-
-define Package/conntrackd/conffiles
-/etc/conntrackd/
-endef
-
-define Package/conntrackd/description
- Conntrackd can replicate the status of the connections that are
- currently being processed by your stateful firewall based on Linux.
- Conntrackd can also run as statistics daemon.
-endef
-
-define Package/conntrackd/install
-       $(INSTALL_DIR) \
-               $(1)/etc/conntrackd \
-               $(1)/etc/init.d \
-               $(1)/usr/sbin
-       $(INSTALL_BIN)  $(PKG_INSTALL_DIR)/usr/sbin/conntrackd $(1)/usr/sbin/
-       $(INSTALL_BIN) ./files/conntrackd.init $(1)/etc/init.d/conntrackd
-endef
-
-$(eval $(call BuildPackage,conntrack))
-$(eval $(call BuildPackage,conntrackd))
diff --git a/package/network/utils/conntrack-tools/files/conntrackd.init b/package/network/utils/conntrack-tools/files/conntrackd.init
deleted file mode 100644 (file)
index 0e2945c..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2015 OpenWrt.org
-
-START=21
-STOP=89
-
-USE_PROCD=1
-PROG="/usr/sbin/conntrackd"
-
-start_service() {
-       [ -e /etc/conntrackd/conntrackd.conf ] || return
-       procd_open_instance
-
-       procd_set_param command $PROG -C /etc/conntrackd/conntrackd.conf
-       procd_set_param respawn
-
-       procd_close_instance
-}