odhcp6c: Add option to override interface identifier in RA-client
authorSteven Barth <cyrus@openwrt.org>
Tue, 18 Jun 2013 12:51:14 +0000 (12:51 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 18 Jun 2013 12:51:14 +0000 (12:51 +0000)
SVN-Revision: 36959

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index 125dea8409ccf3d33b01aa20786bb1e46f071cf2..9d39fdfa3741e189be065c5907060f94b0328090 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-06-13
+PKG_VERSION:=2013-06-18
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=83114b179091cb080f09cf4142ee1c9949ea4e30
+PKG_SOURCE_VERSION:=eaf3a11cad8a5dd389d5f52cc76e424e0242074b
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
index b2264ed907f3492083250107215b2e8a8eb4a7a9..c5e77c65b475dbfd1c69b17faa65dc8aaf446715 100755 (executable)
@@ -18,8 +18,8 @@ proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
-       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
+       local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
+       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
 
 
        # Configure
@@ -35,6 +35,8 @@ proto_dhcpv6_setup() {
 
        [ "$norelease" = "1" ] && append opts "-k"
 
+       [ -n "$ifaceid" ] && append opts "-i$ifaceid"
+
        for opt in $reqopts; do
                append opts "-r$opt"
        done