mt76: update to the latest version
authorFelix Fietkau <nbd@nbd.name>
Tue, 6 Nov 2018 21:25:06 +0000 (22:25 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 6 Nov 2018 21:25:49 +0000 (22:25 +0100)
172f081 mt76x0: do not overwrite other MT_BBP(AGC, 8) fields
2ae2046 mt76x0: phy: use mt76_poll_msec in mt76x0_phy_temp_sensor
add66a0 mt76x0: init: use mt76x02_mac_shared_key_setup in mt76x0_init_hardware
1f24db9 mt76x2: move wcid_tx_rate conf at bootstrap
097b2bd mt76x0: init: use mt76x02_mac_wcid_setup for wcid configuration
d0eb03e mt76x2u: init: remove not useful configuration
c7aa8f4 mt76x2u: init: use common routines for wcid/key initialization
bd568d9 mt76: move mt76x02_eeprom_copy in mt76x02-lib module
57b441d mt76x0: phy: introduce tssi calibration support
a78802c mt76x0: phy: use tssi reported value to configure tx power if available
94ad030 mt76: remove mcu_msg_alloc
15cb426 mt76: remove wait argument from mt76x02_mcu_function_select
cd76a83 mt76: remove wait argument from mt76x02_mcu_set_radio_state
9b97e0f mt76x02: run calibration after scanning
663b197 mt76x02: assure we update gain after scan
eb53745 mt76x0: dfs: fix IBI_R11 configuration on non-radar channels
ef06c30 mt76: avoid queue/status spinlocks while passing tx status to mac80211
5195257 mt7603: fix maximum rx frame size
01815e9 mt7603: use mutex from struct mt76_dev
3c8e8a7 mt7603: use irq_lock/irqmask from struct mt76_dev
8b7f50d mt76: add size check for additional rx fragments
87bad3a mt7603: stop MAC on watchdog reset
c34baab mt7603: add missing unlock in case changing the channel fails
ac6fc78 mt7603: add debugfs file to trigger watchdog resets
d9b5324 mt7603: add SPDX license identifiers
498d716 mt7603: fix checkpatch issues
a1afefd mt7603: fix handling of fixed rate packets
5ee0523 mt7603: fix tx status rate reporting for fixed-rate packets

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mt76/Makefile

index edf4fdacc7f92f7916f3d5311b499206cf65c3b6..90804c80bdf83eca65907ce507a9b0bf15367a7f 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2018-10-27
-PKG_SOURCE_VERSION:=fdc63f168eeb64e1849852cbd242ef7b93d9e0ac
-PKG_MIRROR_HASH:=93dfa4d980fc55d4a1f2e495657d2495af5222a70f57f5f4a49c64c845fa3faa
+PKG_SOURCE_DATE:=2018-11-06
+PKG_SOURCE_VERSION:=5ee05239fafa8cb65fa0d69c230ddb8b26f993b5
+PKG_MIRROR_HASH:=0bee1f6b78da666a5acb240eaa2321336fd7102f959e917f377d9b9c29072f57
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_BUILD_PARALLEL:=1