switch to gcc-4.4.1 and enabled octeon specific optimizations
authorFlorian Fainelli <florian@openwrt.org>
Sat, 26 Sep 2009 18:23:43 +0000 (18:23 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 26 Sep 2009 18:23:43 +0000 (18:23 +0000)
SVN-Revision: 17743

target/linux/octeon/Makefile
toolchain/gcc/Config.in
toolchain/gcc/Config.version

index 673b1b5b89a49e4a45daa2c18638ced4c87d40de..56c54ef4bd99c2973cb923db0c11e47fc9cea2fe 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
 FEATURES:=squashfs jffs2 pci
-CFLAGS:=-Os -pipe -funit-at-a-time
+CFLAGS:=-Os -pipe -mtune=octeon -funit-at-a-time
 
 LINUX_VERSION:=2.6.30.7
 
index de0bbafbc8784ae190c97d644fb7b608ed7a6bb2..873dbfcdc2e09dac12853359657702994dec7aa3 100644 (file)
@@ -10,6 +10,7 @@ choice
        default GCC_VERSION_4_3_3 if TARGET_etrax
        default GCC_VERSION_4_3_3 if TARGET_coldfire
        default GCC_VERSION_4_4_0 if ubicom32
+       default GCC_VERSION_4_4_1 if TARGET_octeon
        default GCC_VERSION_4_1_2
        help
          Select the version of gcc you wish to use.
index c99b14c27e3fe58671962664a0a8956a61b05663..3f7b65715ae9138203c3692e8cb9544df4cd5790 100644 (file)
@@ -58,4 +58,7 @@ if !TOOLCHAINOPTS
 
        config GCC_VERSION_4_4_0
                default y if ubicom32
+
+       config GCC_VERSION_4_4_1
+               default y if TARGET_octeon
 endif