libjson-c: update to 0.13.1
authorDeng Qingfang <dengqf6@mail2.sysu.edu.cn>
Tue, 30 Apr 2019 13:43:25 +0000 (21:43 +0800)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Wed, 19 Jun 2019 20:44:28 +0000 (22:44 +0200)
Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
package/libs/libjson-c/Makefile
package/libs/libjson-c/patches/000-libm.patch

index 23cc7b5de4595fba65c09143bd5ef47c2bdaef04..b61d99cc99f64714e6d373a1bfde9e2176487c1e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=json-c
-PKG_VERSION:=0.12.1
-PKG_RELEASE:=3
+PKG_VERSION:=0.13.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nodoc.tar.gz
 PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
-PKG_HASH:=5a617da9aade997938197ef0f8aabd7f97b670c216dc173977e1d56eef9e1291
+PKG_HASH:=94a26340c0785fcff4f46ff38609cf84ebcd670df0c8efd75d039cc951d80132
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
 
@@ -38,7 +38,7 @@ define Package/libjson-c
   CATEGORY:=Libraries
   TITLE:=javascript object notation
   URL:=https://json-c.github.io/json-c/
-  ABI_VERSION:=2
+  ABI_VERSION:=4
 endef
 
 define Package/libjson-c/description
index 45adb0597f238e44877ca9dc9bf31ecb80cbe684..de98e35d4346d37c84483cf1748491156c1dbead 100644 (file)
@@ -1,8 +1,8 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -43,12 +43,6 @@
- AC_FUNC_MALLOC
- AC_FUNC_REALLOC
+@@ -76,12 +76,6 @@ AC_FUNC_VPRINTF
+ AC_FUNC_MEMCMP
+ AC_CHECK_FUNCS([realloc])
  AC_CHECK_FUNCS(strcasecmp strdup strerror snprintf vsnprintf vasprintf open vsyslog strncasecmp setlocale)
 -AC_CHECK_DECLS([INFINITY], [], [], [[#include <math.h>]])
 -AC_CHECK_DECLS([nan], [], [], [[#include <math.h>]])
 -AC_CHECK_DECLS([isinf], [], [], [[#include <math.h>]])
 -AC_CHECK_DECLS([_isnan], [], [], [[#include <float.h>]])
 -AC_CHECK_DECLS([_finite], [], [], [[#include <float.h>]])
- #check if .section.gnu.warning accepts long strings (for __warn_references)
- AC_LANG_PUSH([C])
+ AC_MSG_CHECKING(for GCC atomic builtins)
+ AC_LINK_IFELSE(
+ [
 --- a/math_compat.h
 +++ b/math_compat.h
-@@ -1,28 +1,9 @@
- #ifndef __math_compat_h
- #define __math_compat_h
+@@ -6,31 +6,9 @@
+  * @brief Do not use, json-c internal, may be changed or removed at any time.
+  */
  
--/* Define isnan and isinf on Windows/MSVC */
+-/* Define isnan, isinf, infinity and nan on Windows/MSVC */
 -
 -#ifndef HAVE_DECL_ISNAN
 -# ifdef HAVE_DECL__ISNAN
 -# endif
 -#endif
 -
--#ifndef HAVE_DECL_NAN
--#error This platform does not have nan()
+-#ifndef HAVE_DECL_INFINITY
+-#include <float.h>
+-#define INFINITY (DBL_MAX + DBL_MAX)
+-#define HAVE_DECL_INFINITY
 -#endif
 -
--#ifndef HAVE_DECL_INFINITY
--#error This platform does not have INFINITY
+-#ifndef HAVE_DECL_NAN
+-#define NAN (INFINITY - INFINITY)
+-#define HAVE_DECL_NAN
 -#endif
 +#undef isnan
 +#define isnan(x) __builtin_isnan(x)