kernel: netdevices: Package AMD PHY
authorLinus Walleij <linus.walleij@linaro.org>
Mon, 23 Oct 2023 06:43:03 +0000 (08:43 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 25 Oct 2023 09:23:57 +0000 (11:23 +0200)
This adds a package for the AMD and Altima PHY, found in some
odd devices.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
package/kernel/linux/modules/netdevices.mk

index b0d69e022069cac99d827b649ba68bd84cdd72da..9057ec5615152e9d878d632baf2a8877899ee65a 100644 (file)
@@ -224,6 +224,22 @@ endef
 $(eval $(call KernelPackage,phylib-broadcom))
 
 
+define KernelPackage/phy-amd
+   SUBMENU:=$(NETWORK_DEVICES_MENU)
+   TITLE:=AMD PHY driver
+   KCONFIG:=CONFIG_AMD_PHY
+   DEPENDS:=+kmod-libphy
+   FILES:=$(LINUX_DIR)/drivers/net/phy/amd.ko
+   AUTOLOAD:=$(call AutoProbe,amd,1)
+endef
+
+define KernelPackage/phy-amd/description
+   Currently supports the AMD and Altima PHYs.
+endef
+
+$(eval $(call KernelPackage,phy-amd))
+
+
 define KernelPackage/phy-ax88796b
    SUBMENU:=$(NETWORK_DEVICES_MENU)
    TITLE:=Asix PHY driver