kernel: Add CONFIG_RTC to generic config
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 20 Jun 2019 08:49:20 +0000 (10:49 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 20 Jun 2019 10:53:37 +0000 (12:53 +0200)
RTC (the legacy driver) should not really be used, but seems to crop up
after the kernel update. Fix this by disabling it in the generic config.

Fixes the following build issue seen in arm64 or powerpc64:

ARM JTAG DCC console (HVC_DCC) [N/y/?] n
Virtio console (VIRTIO_CONSOLE) [N/m/y/?] n
Enhanced Real Time Clock Support (legacy PC RTC driver) (RTC) [N/m/y/?] (NEW) aborted!

Console input/output is redirected. Run 'make oldconfig' to update configuration.

scripts/kconfig/Makefile:37: recipe for target 'silentoldconfig' failed

This should fix the build on the arm64/generic and the layerscape/64b
targets.

Fixes: 6c5c3a2edccf ("kernel: Update to version 4.4.182")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/arc770/config-4.4
target/linux/archs38/config-4.4
target/linux/generic/config-4.4

index f484de30be3c8584aa38cdc229c4690f27f73d2f..d89d8395069cfa0b791f7a84d5575dfe04e46433 100644 (file)
@@ -64,7 +64,6 @@ CONFIG_GENERIC_IO=y
 CONFIG_GENERIC_IRQ_CHIP=y
 CONFIG_GENERIC_IRQ_SHOW=y
 CONFIG_GENERIC_SMP_IDLE_THREAD=y
-# CONFIG_GEN_RTC is not set
 CONFIG_GPIOLIB=y
 CONFIG_GPIO_DEVRES=y
 CONFIG_GPIO_DWAPB=y
@@ -154,7 +153,6 @@ CONFIG_RCU_STALL_COMMON=y
 CONFIG_REGMAP=y
 CONFIG_REGMAP_MMIO=y
 CONFIG_RESET_CONTROLLER=y
-# CONFIG_RTC is not set
 # CONFIG_SCHED_INFO is not set
 # CONFIG_SCSI_DMA is not set
 CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
index a09c7c4b61a553c9f0e8f89e4b897d55abd86d6d..269cd95ef0741e59c937f878f842f35a55a9d44f 100644 (file)
@@ -70,7 +70,6 @@ CONFIG_GENERIC_IRQ_CHIP=y
 CONFIG_GENERIC_IRQ_SHOW=y
 CONFIG_GENERIC_PENDING_IRQ=y
 CONFIG_GENERIC_SMP_IDLE_THREAD=y
-# CONFIG_GEN_RTC is not set
 CONFIG_GPIOLIB=y
 CONFIG_GPIO_DEVRES=y
 CONFIG_GPIO_DWAPB=y
@@ -166,7 +165,6 @@ CONFIG_REGMAP_MMIO=y
 CONFIG_RESET_CONTROLLER=y
 CONFIG_RFS_ACCEL=y
 CONFIG_RPS=y
-# CONFIG_RTC is not set
 # CONFIG_SCHED_INFO is not set
 # CONFIG_SCSI_DMA is not set
 CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
index 997d332061acb439fb7e693267cb5644b5658591..38f423c9942f4bcfef4769c78977581cfa9f246a 100644 (file)
@@ -1200,6 +1200,7 @@ CONFIG_GENERIC_NET_UTILS=y
 # CONFIG_GENERIC_PHY is not set
 # CONFIG_GENEVE is not set
 # CONFIG_GENWQE is not set
+# CONFIG_GEN_RTC is not set
 # CONFIG_GFS2_FS is not set
 # CONFIG_GIGASET_CAPI is not set
 # CONFIG_GIGASET_DEBUG is not set
@@ -3183,6 +3184,7 @@ CONFIG_RFKILL=y
 # CONFIG_RPCSEC_GSS_KRB5 is not set
 # CONFIG_RPR0521 is not set
 # CONFIG_RT2X00 is not set
+# CONFIG_RTC is not set
 # CONFIG_RTC_CLASS is not set
 # CONFIG_RTC_DEBUG is not set
 # CONFIG_RTC_DRV_ABB5ZES3 is not set