kernel: bump 5.10 to 5.10.120
authorJohn Audia <therealgraysky@proton.me>
Mon, 6 Jun 2022 11:05:18 +0000 (07:05 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 6 Jun 2022 17:20:02 +0000 (19:20 +0200)
All patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800, x86/64

Signed-off-by: John Audia <therealgraysky@proton.me>
include/kernel-5.10
target/linux/ath25/patches-5.10/700-swconfig_mvswitch.patch
target/linux/generic/backport-5.10/610-v5.13-10-netfilter-nftables-update-table-flags-from-the-commi.patch
target/linux/generic/hack-5.10/251-kconfig.patch
target/linux/generic/hack-5.10/253-ksmbd-config.patch
target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
target/linux/generic/pending-5.10/530-jffs2_make_lzma_available.patch
target/linux/ipq40xx/patches-5.10/707-net-phy-Add-Qualcom-QCA807x-driver.patch
target/linux/realtek/patches-5.10/705-add-rtl-phy.patch

index f12a386aa517f91cfa669052d99f02557a73486d..168fc255e5db27d25d3b6387e47b15421f6ec110 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .119
-LINUX_KERNEL_HASH-5.10.119 = 3e353e55a2b7074c905c7c517c6dae83eae440f98a12ffd471dc4df1d5172511
+LINUX_VERSION-5.10 = .120
+LINUX_KERNEL_HASH-5.10.120 = 5b7a756004158ece2f5e41795ba523ec201743a736e34ce41cbe09177f7d0e8b
index 32f332189bdf888276c9efebc1b3d25a65623698..79a4d1c1a03045f94b717fae98c37f98ed0f98cd 100644 (file)
@@ -13,8 +13,8 @@
        select SWCONFIG
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -29,6 +29,7 @@ obj-$(CONFIG_ADM6996_PHY)    += adm6996.o
obj-$(CONFIG_AR8216_PHY)      += ar8216.o ar8327.o
+@@ -31,6 +31,7 @@ ar8xxx-y                     += ar8216.o
ar8xxx-y                      += ar8327.o
  obj-$(CONFIG_SWCONFIG_B53)    += b53/
  obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
 +obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
index fa6e0c4173533dc2305f96d25b5142a81ec4a6af..55c04ba4fdffb31f5126fd3004454171f50a3736 100644 (file)
@@ -70,7 +70,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        nft_trans_table_update(trans) = true;
        list_add_tail(&trans->list, &ctx->net->nft.commit_list);
        return 0;
-@@ -7908,11 +7912,10 @@ static int nf_tables_commit(struct net *
+@@ -7918,11 +7922,10 @@ static int nf_tables_commit(struct net *
                switch (trans->msg_type) {
                case NFT_MSG_NEWTABLE:
                        if (nft_trans_table_update(trans)) {
@@ -86,7 +86,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                        } else {
                                nft_clear(net, trans->ctx.table);
                        }
-@@ -8125,11 +8128,9 @@ static int __nf_tables_abort(struct net
+@@ -8135,11 +8138,9 @@ static int __nf_tables_abort(struct net
                switch (trans->msg_type) {
                case NFT_MSG_NEWTABLE:
                        if (nft_trans_table_update(trans)) {
index 34a63eaa7c4cb5d1839bd120884bc62529802416..4ada399fbf0e283318528a45a21985cb5f3fa1e1 100644 (file)
@@ -92,7 +92,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        bool
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -418,16 +418,16 @@ config BCH_CONST_T
+@@ -420,16 +420,16 @@ config BCH_CONST_T
  # Textsearch support is select'ed if needed
  #
  config TEXTSEARCH
index c2b2a96b9cc95ccf68fabb48c2c9a29808179457..adce3f5f154881bd500c1ad3b80b48a8d04c112a 100644 (file)
@@ -11,7 +11,7 @@
          that can be interpreted by the ASN.1 stream decoder and used to
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -589,7 +589,7 @@ config LIBFDT
+@@ -591,7 +591,7 @@ config LIBFDT
        bool
  
  config OID_REGISTRY
index dfba811f31f20e6e3e7c30ed2afc7291b92228cf..4ffd8cfa37dd8e81dfa2308dcf234cd2479bdb43 100644 (file)
@@ -4,7 +4,7 @@ from backports.
 
 --- a/lib/crypto/Kconfig
 +++ b/lib/crypto/Kconfig
-@@ -4,7 +4,7 @@ config CRYPTO_LIB_AES
+@@ -6,7 +6,7 @@ config CRYPTO_LIB_AES
        tristate
  
  config CRYPTO_LIB_ARC4
index 20483a391dddbeacd3e7a44403a2e7789d31616f..d30d3b756000728676813ca9f96f7fc49da5b536 100644 (file)
@@ -1087,7 +1087,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
  #define JFFS2_NODE_ACCURATE 0x2000
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -315,6 +315,12 @@ config ZSTD_DECOMPRESS
+@@ -317,6 +317,12 @@ config ZSTD_DECOMPRESS
  
  source "lib/xz/Kconfig"
  
index ba441022f320307d9df1e48ffc70307817c80c51..12b21a803ce2ae4e4b744303ecaa8afcb41720fb 100644 (file)
@@ -40,7 +40,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
        help
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -86,6 +86,7 @@ obj-$(CONFIG_MICROSEMI_PHY)  += mscc/
+@@ -88,6 +88,7 @@ obj-$(CONFIG_MICROSEMI_PHY)  += mscc/
  obj-$(CONFIG_NATIONAL_PHY)    += national.o
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
index 4f907e1d4b83ff2f5285a72581e74edd595b0810..e88c26b3487f8a5dee5a6b14244d1079a2a5305d 100644 (file)
@@ -15,7 +15,7 @@
        help
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -87,6 +87,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
+@@ -89,6 +89,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o