image: remove bogus mkimage command
authorDaniel Golle <daniel@makrotopia.org>
Thu, 25 Feb 2021 14:06:14 +0000 (14:06 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 25 Feb 2021 14:07:20 +0000 (14:07 +0000)
That was a left-over from testing and should not have made it into the
tree. Remove it.

Fixes: 330bd380e8 ("image: allow building FIT and uImage with ramdisk")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/image-commands.mk

index d4ec51ca7cd0578510cbf846c9fff3df6fc076be..a1edc3265e3bd979c0ed62fd35faf3bccfd84396 100644 (file)
@@ -461,22 +461,6 @@ define Build/uImage
        mv $@.new $@
 endef
 
-define Build/uImage-with-ramdisk
-       mkimage \
-               -A $(LINUX_KARCH) \
-               -O linux \
-               -T kernel \
-               -C $(word 1,$(1)) \
-               -a $(KERNEL_LOADADDR) \
-               -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -i $(KERNEL_BUILD_DIR)/initrd.cpio.$(strip $(call Build/initrd_compression)) \
-               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
-               $(if $(UIMAGE_MAGIC),-M $(UIMAGE_MAGIC)) \
-               $(wordlist 2,$(words $(1)),$(1)) \
-               -d $@ $@.new
-       mv $@.new $@
-endef
-
 define Build/xor-image
        $(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor $(1)
        mv $@.xor $@