ar71xx: build firmware image for the TL-WR841N v7
authorGabor Juhos <juhosg@openwrt.org>
Mon, 27 Sep 2010 14:53:54 +0000 (14:53 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 27 Sep 2010 14:53:54 +0000 (14:53 +0000)
SVN-Revision: 23134

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 6e55772b3db23bd9877486381d144441e6d2f5ce..bad87447513db044be78aed080d316efb96ef2e3 100644 (file)
@@ -60,6 +60,17 @@ endef
 
 $(eval $(call Profile,TLWR841NDV5))
 
+define Profile/TLWR841NDV7
+       NAME:=TP-LINK TL-WR841ND v7
+       PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR841NDV7/Description
+       Package set optimized for the TP-LINK TL-WR841ND v7.
+endef
+
+$(eval $(call Profile,TLWR841NDV7))
+
 define Profile/TLWR941NDV2
        NAME:=TP-LINK TL-WR941ND v2
        PACKAGES:=kmod-ath9k wpad-mini
index 3fa49ba36e5fa32145544e639fb237abc0236dfb..0c348565ffae0306a3e0d8f1d986d59c6f9af88b 100644 (file)
@@ -551,6 +551,10 @@ define Image/Build/Profile/TLWR841NDV5
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr841nd-v5,board=TL-WR741ND,TL-WR841NDv5)
 endef
 
+define Image/Build/Profile/TLWR841NDV7
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr841nd-v7,board=TL-WR741ND,TL-WR841NDv7)
+endef
+
 define Image/Build/Profile/TLWR941NDV2
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v2,board=TL-WR941ND,TL-WR941NDv2)
 endef
@@ -620,6 +624,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR841NV15,$(1))
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))
+       $(call Image/Build/Profile/TLWR841NDV7,$(1))
        $(call Image/Build/Profile/TLWR941NDV2,$(1))
        $(call Image/Build/Profile/TLWR941NDV3,$(1))
        $(call Image/Build/Profile/TLWR941NDV4,$(1))