ipq40xx: convert Buffalo WTR-M2133HP to DSA
authorYanase Yuki <dev@zpc.sakura.ne.jp>
Wed, 31 May 2023 07:41:59 +0000 (16:41 +0900)
committerChristian Lamparter <chunkeey@gmail.com>
Thu, 1 Jun 2023 21:54:20 +0000 (23:54 +0200)
This commit convert WTR-M2133HP to DSA setup.

Signed-off-by: Yanase Yuki <dev@zpc.sakura.ne.jp>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-wtr-m2133hp.dts
target/linux/ipq40xx/image/generic.mk

index d6b19c981eab991f7b5e26a288273002e28a6506..b131d0d6182fe4edb3ca3c25894b71e6843cddf4 100644 (file)
@@ -82,6 +82,7 @@ ipq40xx_setup_interfaces()
                ucidef_set_interface_lan "sw-eth1 sw-eth2"
                ;;
        aruba,ap-303h|\
+       buffalo,wtr-m2133hp|\
        ezviz,cs-w3-wd1200g-eup|\
        netgear,rbr50|\
        netgear,rbs50|\
index f1d58ccba916d2db37614be2f91edecfa2a25fb7..3260de23bd40897ee407b69d874bffc99ababad1 100644 (file)
        qcom,ath10k-calibration-variant = "Buffalo-WTR-M2133HP";
 };
 
+&switch {
+       status = "okay";
+};
+
+&swport2 {
+       status = "okay";
+       label = "lan3";
+};
+
+&swport3 {
+       status = "okay";
+       label = "lan2";
+};
+
+&swport4 {
+       status = "okay";
+       label = "lan1";
+};
+
+&swport5 {
+       status = "okay";
+};
+
+&gmac {
+       status = "okay";
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_orgdata_20>;
+};
+
 &mdio {
        status = "okay";
        pinctrl-0 = <&mdio_pins>;
index 7c7a4acc5ca00266653fcc76dbbc9275a5b36aa3..59d4f082ff8b481490fe6ebbfc909b264183d745 100644 (file)
@@ -305,8 +305,7 @@ define Device/buffalo_wtr-m2133hp
        BLOCKSIZE := 128k
        PAGESIZE := 2048
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += buffalo_wtr-m2133hp
+TARGET_DEVICES += buffalo_wtr-m2133hp
 
 define Device/cellc_rtl30vw
        KERNEL_SUFFIX := -zImage.itb