kernel: bump 5.4 to 5.4.140
authorJohn Audia <graysky@archlinux.us>
Thu, 12 Aug 2021 13:28:18 +0000 (09:28 -0400)
committerDavid Bauer <mail@david-bauer.net>
Sat, 14 Aug 2021 18:25:25 +0000 (20:25 +0200)
Removed upstreamed bcm27xx/patches-5.4:
    950-0977-USB-gadget-f_hid-avoid-crashes-and-log-spam.patch
    950-0980-SQUASH-USB-gadget-f_hid-remove-more-spam.patch

All other patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/bcm27xx/patches-5.4/950-0055-Added-Device-IDs-for-August-DVB-T-205.patch
target/linux/bcm27xx/patches-5.4/950-0174-media-videobuf2-Allow-exporting-of-a-struct-dmabuf.patch
target/linux/bcm27xx/patches-5.4/950-0977-USB-gadget-f_hid-avoid-crashes-and-log-spam.patch [deleted file]
target/linux/bcm27xx/patches-5.4/950-0980-SQUASH-USB-gadget-f_hid-remove-more-spam.patch [deleted file]
target/linux/mediatek/patches-5.4/0900-bt-mtk-serial-fix.patch
target/linux/mvebu/patches-5.4/020-arm64-dts-marvell-armada-37xx-Set-pcie_reset_pin-to-.patch
target/linux/mvebu/patches-5.4/021-arm64-dts-marvell-armada-37xx-Move-PCIe-comphy-handl.patch
target/linux/mvebu/patches-5.4/022-arm64-dts-marvell-armada-37xx-Move-PCIe-max-link-spe.patch

index 864c5f7bdc8dcc8a5cb86d079225ba2b97ebb547..013ee6ac4d7f28a81c6f3e7f38ea68a39df8ec1d 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .139
+LINUX_VERSION-5.4 = .140
 LINUX_VERSION-5.10 = .58
 
-LINUX_KERNEL_HASH-5.4.139 = 0471d0ccb7953cdae7d235192588ac5d72344851969962676d1703e69084a37f
+LINUX_KERNEL_HASH-5.4.140 = 2c657a2df4f2e805ac50aeb39ecf5d1e4cb1501e7fcf15eafd14486b587f7e43
 LINUX_KERNEL_HASH-5.10.58 = 732cc56be539e65894621c3b6b2640597d8cf5da17319b82da6e7b4f7828f210
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index a4e4bd1e88966d08159c7f6d4297699c1907d539..f0c1896e336ee8b920d4780fefed186119fa2a2d 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH] Added Device IDs for August DVB-T 205
 
 --- a/drivers/media/usb/dvb-usb-v2/rtl28xxu.c
 +++ b/drivers/media/usb/dvb-usb-v2/rtl28xxu.c
-@@ -1938,6 +1938,10 @@ static const struct usb_device_id rtl28x
+@@ -1947,6 +1947,10 @@ static const struct usb_device_id rtl28x
                &rtl28xxu_props, "Compro VideoMate U650F", NULL) },
        { DVB_USB_DEVICE(USB_VID_KWORLD_2, 0xd394,
                &rtl28xxu_props, "MaxMedia HU394-T", NULL) },
index 74d03540adfc16bf88e36d7f88824b12ca3f74b7..24ea0a971719da3dcc931e479bc9367d004b3a10 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/media/common/videobuf2/videobuf2-core.c
 +++ b/drivers/media/common/videobuf2/videobuf2-core.c
-@@ -2073,12 +2073,12 @@ static int __find_plane_by_offset(struct
+@@ -2084,12 +2084,12 @@ static int __find_plane_by_offset(struct
        return -EINVAL;
  }
  
@@ -35,7 +35,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
        struct dma_buf *dbuf;
  
        if (q->memory != VB2_MEMORY_MMAP) {
-@@ -2128,6 +2128,21 @@ int vb2_core_expbuf(struct vb2_queue *q,
+@@ -2139,6 +2139,21 @@ int vb2_core_expbuf(struct vb2_queue *q,
                return -EINVAL;
        }
  
diff --git a/target/linux/bcm27xx/patches-5.4/950-0977-USB-gadget-f_hid-avoid-crashes-and-log-spam.patch b/target/linux/bcm27xx/patches-5.4/950-0977-USB-gadget-f_hid-avoid-crashes-and-log-spam.patch
deleted file mode 100644 (file)
index 1fe685c..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-From 22198e801db7542c59098a75bdab120bcbc42652 Mon Sep 17 00:00:00 2001
-From: Phil Elwell <phil@raspberrypi.com>
-Date: Wed, 30 Sep 2020 19:23:43 +0100
-Subject: [PATCH] USB: gadget: f_hid: avoid crashes and log spam
-
-Disconnecting and reconnecting the USB cable can lead to crashes and a
-variety of kernel log spam. Try to fix or minimise both.
-
-See: https://github.com/raspberrypi/linux/issues/3870
-
-Signed-off-by: Phil Elwell <phil@raspberrypi.com>
----
- drivers/usb/gadget/function/f_hid.c | 18 +++++++++++++++++-
- 1 file changed, 17 insertions(+), 1 deletion(-)
-
---- a/drivers/usb/gadget/function/f_hid.c
-+++ b/drivers/usb/gadget/function/f_hid.c
-@@ -344,6 +344,11 @@ static ssize_t f_hidg_write(struct file
-       spin_lock_irqsave(&hidg->write_spinlock, flags);
-+      if (!hidg->req) {
-+              spin_unlock_irqrestore(&hidg->write_spinlock, flags);
-+              return -ESHUTDOWN;
-+      }
-+
- #define WRITE_COND (!hidg->write_pending)
- try_again:
-       /* write queue */
-@@ -364,7 +369,13 @@ try_again:
-       count  = min_t(unsigned, count, hidg->report_length);
-       spin_unlock_irqrestore(&hidg->write_spinlock, flags);
--      status = copy_from_user(req->buf, buffer, count);
-+      if (req) {
-+              status = copy_from_user(req->buf, buffer, count);
-+      } else {
-+              ERROR(hidg->func.config->cdev, "hidg->req is NULL\n");
-+              status = -ESHUTDOWN;
-+              goto release_write_pending;
-+      }
-       if (status != 0) {
-               ERROR(hidg->func.config->cdev,
-@@ -393,6 +404,11 @@ try_again:
-       spin_unlock_irqrestore(&hidg->write_spinlock, flags);
-+      if (!hidg->in_ep->enabled) {
-+              ERROR(hidg->func.config->cdev, "in_ep is disabled\n");
-+              status = -ESHUTDOWN;
-+              goto release_write_pending;
-+      }
-       status = usb_ep_queue(hidg->in_ep, req, GFP_ATOMIC);
-       if (status < 0) {
-               ERROR(hidg->func.config->cdev,
diff --git a/target/linux/bcm27xx/patches-5.4/950-0980-SQUASH-USB-gadget-f_hid-remove-more-spam.patch b/target/linux/bcm27xx/patches-5.4/950-0980-SQUASH-USB-gadget-f_hid-remove-more-spam.patch
deleted file mode 100644 (file)
index 3f199cf..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From 5018dc559136e2bca24973e71ed8747adf0f37f3 Mon Sep 17 00:00:00 2001
-From: Phil Elwell <phil@raspberrypi.com>
-Date: Mon, 5 Oct 2020 15:41:15 +0100
-Subject: [PATCH] SQUASH: USB: gadget: f_hid: remove more spam
-
-Tidying up the previous patch to this file dropped the deletion of a
-particularly noisy error message. Restore its removal.
-
-See: https://github.com/raspberrypi/linux/issues/3870
-
-Signed-off-by: Phil Elwell <phil@raspberrypi.com>
----
- drivers/usb/gadget/function/f_hid.c | 2 --
- 1 file changed, 2 deletions(-)
-
---- a/drivers/usb/gadget/function/f_hid.c
-+++ b/drivers/usb/gadget/function/f_hid.c
-@@ -411,8 +411,6 @@ try_again:
-       }
-       status = usb_ep_queue(hidg->in_ep, req, GFP_ATOMIC);
-       if (status < 0) {
--              ERROR(hidg->func.config->cdev,
--                      "usb_ep_queue error on int endpoint %zd\n", status);
-               goto release_write_pending;
-       } else {
-               status = count;
index 12844c860f67362e0d7323f62aa1cce9ad6c0f6a..872b2bad458ec665d32fd49b70b1c18e51ece648 100644 (file)
@@ -19,7 +19,7 @@
        },
        [PORT_NPCM] = {
                .name           = "Nuvoton 16550",
-@@ -2591,6 +2591,11 @@ serial8250_do_set_termios(struct uart_po
+@@ -2597,6 +2597,11 @@ serial8250_do_set_termios(struct uart_po
        unsigned long flags;
        unsigned int baud, quot, frac = 0;
  
index cd15b20ed1f8224db827d2622142148b5880aa5e..dd75470b4de36c352bcf32492700c77e1164a0ed 100644 (file)
@@ -69,7 +69,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
  /* J6 */
 --- a/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
-@@ -126,10 +126,6 @@
+@@ -127,10 +127,6 @@
        };
  };
  
index b42192d9fd062ab50d5f22589c76dfa551a581f7..b851a39a3980619c3f2590cbb7977f29e143c250 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
        reset-gpios = <&gpiosb 3 GPIO_ACTIVE_LOW>;
 --- a/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
-@@ -132,7 +132,6 @@
+@@ -133,7 +133,6 @@
        status = "okay";
        max-link-speed = <2>;
        reset-gpios = <&gpiosb 3 GPIO_ACTIVE_LOW>;
index 43cda3f29f7f90c64de8edfb90ec7cae756d35d9..4442a5ac15a48047344f7884c4cd826997d44e61 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
 
 --- a/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-turris-mox.dts
-@@ -130,7 +130,6 @@
+@@ -131,7 +131,6 @@
        pinctrl-names = "default";
        pinctrl-0 = <&pcie_reset_pins &pcie_clkreq_pins>;
        status = "okay";