ramips: fix Gigabit Ethernet port of the HiWiFi HC5861
authorShiji Yang <yangshiji66@qq.com>
Tue, 26 Sep 2023 12:12:45 +0000 (20:12 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 30 Oct 2023 23:44:03 +0000 (00:44 +0100)
HiWiFi HC5861 has a GbE port which connected to the RTL8211E PHY
chip. This patch adds the missing Realtek PHY driver package and
sets the correct external PHYs base address to make it work again.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
(cherry picked from commit f025135f16e2b3e9398cfd87585d055a1ca31975)

target/linux/ramips/dts/mt7620a_hiwifi_hc5861.dts
target/linux/ramips/image/mt7620.mk

index 87eacb13d7802ff69ead8e48882dcb2cbd930b24..8b37162f26709f5c1c7fd32e43ebf3d34b90f836 100644 (file)
@@ -70,7 +70,7 @@
 
 &ethernet {
        pinctrl-names = "default";
-       pinctrl-0 = <&rgmii1_pins &mdio_pins>;
+       pinctrl-0 = <&mdio_pins>, <&rgmii1_pins>;
 
        nvmem-cells = <&macaddr_factory_4>;
        nvmem-cell-names = "mac-address";
        };
 };
 
+&gsw {
+       mediatek,ephy-base = /bits/ 8 <12>;
+};
+
 &pcie {
        status = "okay";
 };
index 7c2ff740f057262ab73a655a00e5726fd22d6a80..897bbfd3920e6067548b0742c703ba1308cc0eff 100644 (file)
@@ -549,7 +549,7 @@ define Device/hiwifi_hc5861
   DEVICE_VENDOR := HiWiFi
   DEVICE_MODEL := HC5861
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
-       kmod-usb-ledtrig-usbport
+       kmod-phy-realtek kmod-usb-ledtrig-usbport
   SUPPORTED_DEVICES += hc5861
 endef
 TARGET_DEVICES += hiwifi_hc5861