sdk: find kernel modules when KDIR is a symlink
authorKarl Vogel <karl.vogel@gmail.com>
Thu, 29 Nov 2018 08:07:21 +0000 (09:07 +0100)
committerJo-Philipp Wich <jo@mein.io>
Thu, 29 Nov 2018 10:37:04 +0000 (11:37 +0100)
The find statement would not return any results if the KDIR_BASE pointed to a
symlink. Ran into this issue due to a custom Kernel/Prepare that was installing
a symlink to the kernel directory.

The extra slash at the end fixes this scenario and does no harm for targets that
have a proper KDIR.

Signed-off-by: Karl Vogel <karl.vogel@gmail.com>
(cherry picked from commit ae980458abf8299d614f4b34add32e18d054378d)

target/sdk/Makefile

index ae4bce526020b138bfa85fcf211b322216bab01f..7fd85472282423140ea2198e01cac78cd675d6b8 100644 (file)
@@ -82,7 +82,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
        mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
        $(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(SDK_BUILD_DIR)/
        $(TAR) -cf - -C $(TOPDIR) \
-               `cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
+               `cd $(TOPDIR); find $(KDIR_BASE)/ -name \*.ko` \
                `cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \
                        -type f -name '*.bin' -or -name '*.cis' -or -name '*.csp' -or -name '*.dsp' -or -name '*.fw'` \
                $(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \