gemini: only provide squashfs image for storlink-derivates
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 2 Dec 2021 19:04:53 +0000 (20:04 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 3 Dec 2021 23:36:47 +0000 (00:36 +0100)
The itian sq201, raidsonic ib-4220-b and storlink sl93512r
can't boot from ext4. This is because the rootfstype in the
device-tree bootargs is set to "squashfs,jffs2". (And ext4
was not designed for raw NOR flash chips).

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/gemini/image/Makefile

index 9906808c9ed0db01a8bc4dea984f4da78fe48a36..c84f1926dd5394f811167b2776edb8a840727763 100644 (file)
@@ -181,6 +181,7 @@ define Device/storlink-reference
        COMPILE := copy-kernel-$(1).bin
        COMPILE/copy-kernel-$(1).bin := copy-kernel.bin
        IMAGES := factory.bin
+       FILESYSTEMS := squashfs
        IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
                storlink-default-images $(1)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)