build: provide xxd -i with scripts/xxdi.pl
authorPetr Štetiar <ynezz@true.cz>
Tue, 30 Aug 2022 06:45:39 +0000 (08:45 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 6 Sep 2022 06:04:53 +0000 (08:04 +0200)
Dependency on xxd was added in commit c4dd2441e787 ("tools: add xxd
(from vim)") as U-Boot requires xxd to create the default environment
from an external file.

Later in commit 2b94aac7a128 ("tools: xxd: use more convenient source
tarball"), xxd from another source was used instead, but that source is
currently unavailable, so let's fix it by using simple xxdi.pl Perl
script instead.

Fixes: #10555
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/prereq-build.mk

index 6c45327f013b7af0d8de28aa7aa493f71731d936..0a023c2c6f6eceea40a9fdeaa36db420a43cbced 100644 (file)
@@ -202,7 +202,10 @@ $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
        mkdir -p $(dir $@)
        $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
 
-prereq: $(STAGING_DIR_HOST)/bin/mkhash
+$(STAGING_DIR_HOST)/bin/xxd: $(SCRIPT_DIR)/xxdi.pl
+       $(LN) $< $@
+
+prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \