uboot-imx6: drop support for Nitrogen6x/SABRE devices
authorPiotr Dymacz <pepe2k@gmail.com>
Sat, 27 Feb 2021 11:58:55 +0000 (12:58 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Sat, 10 Apr 2021 13:17:59 +0000 (15:17 +0200)
These devices never got officially supported in the tree thus it doesn't
make much sense to waste our infrastructure resources and keep building
dedicated U-Boot images for them.

CC: Petr Štetiar <ynezz@true.cz>
CC: Luka Perkov <luka.perkov@sartura.hr>
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Acked-by: Petr Štetiar <ynezz@true.cz>
package/boot/uboot-imx6/Makefile

index 79acd4abf7424dc540611e00ac185cb9000000fb..8090f0e62aa02a05ef72de75d01ecdec64bf4c08 100644 (file)
@@ -34,34 +34,6 @@ define U-Boot/mx6cuboxi
    HIDDEN:=1
 endef
 
-define U-Boot/mx6sabresd
-  NAME:=SABRE i.MX6Quad board
-endef
-
-define U-Boot/nitrogen6dl
-  NAME:=Nitrogen6x i.MX6Dual-Lite 1GB board
-endef
-
-define U-Boot/nitrogen6dl2g
-  NAME:=Nitrogen6x i.MX6Dual-Lite 2GB board
-endef
-
-define U-Boot/nitrogen6q
-  NAME:=Nitrogen6x/SABRE Lite (MX6Q/1GB)
-endef
-
-define U-Boot/nitrogen6q2g
-  NAME:=Nitrogen6x i.MX6Quad 2GB board
-endef
-
-define U-Boot/nitrogen6s
-  NAME:=Nitrogen6x i.MX6Solo 512MB board
-endef
-
-define U-Boot/nitrogen6s1g
-  NAME:=Nitrogen6x i.MX6Solo 1GB board
-endef
-
 define U-Boot/wandboard
   NAME:=Wandboard Dual Lite/Quad/Solo
   BUILD_DEVICES:=wandboard
@@ -70,13 +42,6 @@ endef
 UBOOT_TARGETS := \
        apalis_imx6 \
        mx6cuboxi \
-       mx6sabresd \
-       nitrogen6dl \
-       nitrogen6dl2g \
-       nitrogen6q \
-       nitrogen6q2g \
-       nitrogen6s \
-       nitrogen6s1g \
        wandboard
 
 UBOOT_MAKE_FLAGS += u-boot.imx