brcm63xx: Add DT support for CT-5365
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:10 +0000 (11:28 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:10 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
[jogo: make linux partition writable]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42237

40 files changed:
target/linux/brcm63xx/dts/ct-5365.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/516-board_96348A-122.patch
target/linux/brcm63xx/patches-3.14/517-RTA1205W_16_uart_fixes.patch
target/linux/brcm63xx/patches-3.14/519_board_CPVA502plus.patch
target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch
target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch
target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/550-alice_gate2_leds.patch
target/linux/brcm63xx/patches-3.14/551-96348gw_a_leds.patch
target/linux/brcm63xx/patches-3.14/553-boards_probe_switch.patch
target/linux/brcm63xx/patches-3.14/554-board_DWVS0_leds_buttons.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/comtrend.mk

diff --git a/target/linux/brcm63xx/dts/ct-5365.dts b/target/linux/brcm63xx/dts/ct-5365.dts
new file mode 100644 (file)
index 0000000..2ada4f8
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "Comtrend CT-5365";
+       compatible = "comtrend,ct-5365", "brcm,bcm6348";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x3e0000>;
+       };
+
+       nvram@3f0000 {
+               label = "nvram";
+               reg = <0x3f0000 0x010000>;
+       };
+};
index ac644670407ae7a716e3595917287e01f1ca7c12..487d6746b387f2de029dd10ba0dfc77f9d3f86b0 100755 (executable)
@@ -238,7 +238,6 @@ define Image/Build
        $(call Image/Build/CFE,$(1),6338W,6338,6338W-generic,,)
        $(call Image/Build/CFE,$(1),96348GW-11,6348,96348GW-11-generic)
        $(call Image/Build/CFE,$(1),96348GW-10,6348,96348GW-10-generic)
-       $(call Image/Build/CFE,$(1),96348A-122,6348,96348A-122-generic)
        $(call Image/Build/CFE,$(1),96358VW,6358,96358VW-generic)
        $(call Image/Build/CFE,$(1),96358VW2,6358,96358VW2-generic)
        $(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
@@ -362,6 +361,8 @@ $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-16M-fl
 $(eval $(call CfeImageDTB,AR1004G,ar1004g,96348GW-10,6348,AR1004G))
 # Comtrend 536, 5621
 $(eval $(call CfeImageDTB,CT536_CT5621,ct536plus,96348GW-11,6348,CT536_CT5621))
+# Comtrend CT-5365
+$(eval $(call CfeImageDTB,CT5365,ct-5365,96348A-122,6348,CT-5365))
 # D-Link DSL-2740B/DSL-2741B, rev C2
 $(eval $(call CfeImageDTB,DSL274XB_C,dsl-274xb-c,96358GW,6358,DSL274XB-C2))
 # D-Link DSL-2740B/DSL-2741B, rev C3
index 398e4a80b65201861c204052ee3e81a04cf2aba1..cc2690740fde46ad7efcdf7e923fa8510f7abc82 100644 (file)
@@ -1,11 +1,12 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -592,6 +592,76 @@ static struct board_info __initdata boar
+@@ -592,6 +592,77 @@ static struct board_info __initdata boar
        },
  };
  
 +static struct board_info __initdata board_96348A_122 = {
 +      .name                           = "96348A-122",
++      .of_board_id                    = "comtrend,ct-5365",
 +      .expected_cpu_id                = 0x6348,
 +
 +      .has_uart0                      = 1,
@@ -77,7 +78,7 @@
  static struct board_info __initdata board_96348gw = {
        .name                           = "96348GW",
        .of_board_id                    = "brcm,bcm96348gw",
-@@ -1864,6 +1934,7 @@ static const struct board_info __initcon
+@@ -1864,6 +1935,7 @@ static const struct board_info __initcon
        &board_V2500V_BB,
        &board_V2110,
        &board_ct536_ct5621,
index f308890b3bd14532eebaf329f6cf59b4c9506574..1a2dda7222f14c3de36212e70b1aa0c7edae8407 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -871,6 +871,7 @@ static struct board_info __initdata boar
+@@ -872,6 +872,7 @@ static struct board_info __initdata boar
        .of_board_id                    = "dynalink,rta1025w",
        .expected_cpu_id                = 0x6348,
  
index 26989afa53be7fffa4f2db0d7cb7dc6901693d9b..55d1b986c6be92453b3c4aef3bd8dcc8a97c42e9 100644 (file)
@@ -41,7 +41,7 @@
  
  static struct board_info __initdata board_ct536_ct5621 = {
        .name                           = "CT536_CT5621",
-@@ -1936,6 +1970,7 @@ static const struct board_info __initcon
+@@ -1937,6 +1971,7 @@ static const struct board_info __initcon
        &board_V2110,
        &board_ct536_ct5621,
        &board_96348A_122,
index b83d564e21efdda44d788e40980596bd61d1e991..59075d41eaff29e66f3061a5c3f05a2213aede9f 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1934,6 +1934,85 @@ static struct board_info __initdata boar
+@@ -1935,6 +1935,85 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
@@ -96,7 +96,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -1985,6 +2064,10 @@ static const struct board_info __initcon
+@@ -1986,6 +2065,10 @@ static const struct board_info __initcon
        &board_HW553,
        &board_spw303v,
  #endif
index a6e15d5043133e7167da6acdd70eb847effe579a..67df6d61a149d485f7c9b903d96ccbe02aafaa15 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2010,6 +2010,72 @@ static struct board_info __initdata boar
+@@ -2011,6 +2011,72 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
@@ -82,7 +82,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -2067,6 +2133,7 @@ static const struct board_info __initcon
+@@ -2068,6 +2134,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
index fece4c63d7da76830a23012274e07c36219f7ace..074e526a302dccbd7d3007376b34f8cfde38537c 100644 (file)
@@ -86,7 +86,7 @@ Subject: [PATCH] MIPS: BCM63XX: add 963281TAN reference board
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2119,6 +2189,7 @@ static const struct board_info __initcon
+@@ -2120,6 +2190,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 95c53d3743113e258ead219fb49a39b8f31f6ef8..b27c234a72fd09ea90f633f5cea9b34a23a99a74 100644 (file)
@@ -122,7 +122,7 @@ Subject: [PATCH 70/79] MIPS: BCM63XX: Add board definition for D-Link
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2190,6 +2295,7 @@ static const struct board_info __initcon
+@@ -2191,6 +2296,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 35361ec259ab90f21a33fe7954bd24731e079b6d..d0059a6797fdca708fa6aef55d585d9e0e79ee6e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1174,6 +1174,59 @@ static struct board_info __initdata boar
+@@ -1175,6 +1175,59 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
  };
  
@@ -60,7 +60,7 @@
  static struct board_info __initdata board_96348_D4PW = {
        .name                           = "D-4P-W",
        .expected_cpu_id                = 0x6348,
-@@ -2325,6 +2378,7 @@ static const struct board_info __initcon
+@@ -2326,6 +2379,7 @@ static const struct board_info __initcon
        &board_ct536_ct5621,
        &board_96348A_122,
        &board_CPVA502plus,
index 05f4c9e7782865a15fa69eb4620d0fcf36242119..5d4c6208fb51982066c19a45004f5b8caa6b1fee 100644 (file)
@@ -13,7 +13,7 @@
  /*
   * known 3368 boards
   */
-@@ -2049,6 +2055,124 @@ static struct board_info __initdata boar
+@@ -2050,6 +2056,124 @@ static struct board_info __initdata boar
        .num_spis = ARRAY_SIZE(nb4_spi_devices),
  };
  
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -2390,6 +2514,7 @@ static const struct board_info __initcon
+@@ -2391,6 +2515,7 @@ static const struct board_info __initcon
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
index 91de06cf9afe26497faed6c1ddd44bdeb87c2287..0f00c4ef08a14dd5a9d491e4c588e7b41f1994e8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2315,6 +2315,74 @@ static struct board_info __initdata boar
+@@ -2316,6 +2316,74 @@ static struct board_info __initdata boar
                },
        }
  };
@@ -75,7 +75,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -2517,6 +2585,7 @@ static const struct board_info __initcon
+@@ -2518,6 +2586,7 @@ static const struct board_info __initcon
        &board_ct6373_1,
        &board_HW553,
        &board_spw303v,
index 47b8d05f8b3c8e9d4aeae1e0db448313b638c069..2171a698734e1dfa09ad05f8882aa47d12eda9ac 100644 (file)
@@ -17,7 +17,7 @@
  
  #define CT6373_PID_OFFSET             0xff80
  #define CT6373_74X164_GPIO_BASE       64
-@@ -2385,6 +2388,105 @@ static struct board_info __initdata boar
+@@ -2386,6 +2389,105 @@ static struct board_info __initdata boar
  };
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
   * known 6368 boards
   */
-@@ -2588,6 +2690,10 @@ static const struct board_info __initcon
+@@ -2589,6 +2691,10 @@ static const struct board_info __initcon
        &board_DVAG3810BN,
  #endif
  
index 6afcf3cc46b415170efb02eba42a3b2b51f310dc..8b368f3fe051a40a1f48237c8eb87d11880f0767 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1116,6 +1116,57 @@ static struct board_info __initdata boar
+@@ -1117,6 +1117,57 @@ static struct board_info __initdata boar
        .has_ehci0                      = 1,
  };
  
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_rta1025w_16 = {
        .name                           = "RTA1025W_16",
        .of_board_id                    = "dynalink,rta1025w",
-@@ -2661,6 +2712,7 @@ static const struct board_info __initcon
+@@ -2662,6 +2713,7 @@ static const struct board_info __initcon
        &board_96348gw_10,
        &board_96348gw_11,
        &board_FAST2404,
index 190050578650afe062744ffa6f687b024e861558..f3e0bad40584820426272933d704f1c76ff50c93 100644 (file)
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
-@@ -2693,6 +2820,7 @@ static const struct board_info __initcon
+@@ -2694,6 +2821,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 9b6a317c1e50cfa95ab5f116e639b6e0524e5c71..dd3d8880e3c4d7a83597c1537ea839c18cd94fa5 100644 (file)
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .expected_cpu_id                = 0x6328,
-@@ -2819,6 +2928,7 @@ static const struct board_info __initcon
+@@ -2820,6 +2929,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 025f0654a243ec2fa4b1482576e0943a39c3c201..996d6eaed99405cf66a76acfff8497744cb7cda9 100644 (file)
@@ -92,7 +92,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2928,6 +3013,7 @@ static const struct board_info __initcon
+@@ -2929,6 +3014,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 227fd44f1b6bfb269995d0c8d5eae7a6a29347a6..fd464745285479eb90bc9ad134ee8ff8d0f874bb 100644 (file)
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3027,6 +3076,7 @@ static const struct board_info __initcon
+@@ -3028,6 +3077,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index 0278820885734540f0eadcead7e5024366a663b7..5fb3bade979547fb04a0765ab485109198854e0d 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -2674,6 +2675,405 @@ static struct board_info __initdata boar
+@@ -2675,6 +2676,405 @@ static struct board_info __initdata boar
        },
  };
  
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3112,6 +3512,9 @@ static const struct board_info __initcon
+@@ -3113,6 +3513,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index 6b1e5f297b5c599b02163fd7f2cbf7cf279b0094..58c5961ed8e1d50cc74ec2d437e7d6ed33b8e7a1 100644 (file)
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3477,6 +3531,7 @@ static const struct board_info __initcon
+@@ -3478,6 +3532,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index c456e9f469f5754ede1a0645132ead721f0f2045..ff76fbda926375008fc41b88a5123fbefd4326c1 100644 (file)
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3521,6 +3637,7 @@ static const struct board_info __initcon
+@@ -3522,6 +3638,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index 165737d35dff00ebebb2310b57eba80447519d9c..387602097f52cb947552d220f409c5b7d80f69d8 100644 (file)
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3476,6 +3476,96 @@ static struct board_info __initdata boar
+@@ -3477,6 +3477,96 @@ static struct board_info __initdata boar
        .devs = nb6_devices,
        .num_devs = ARRAY_SIZE(nb6_devices),
  };
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3693,6 +3783,7 @@ static const struct board_info __initcon
+@@ -3694,6 +3784,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index fcbe45d60c6f02c68818fa69ea2ba26f23af11de..8245cbbfdf92ef722df8e69540fc6de099aefd30 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2302,6 +2302,99 @@ static struct board_info __initdata boar
+@@ -2303,6 +2303,99 @@ static struct board_info __initdata boar
  
        .has_ohci0 = 1,
        .has_ehci0 = 1,
index 997750279af90a53d071ab59af7799bce4c05193..43a841e1d14abb02ab2bd718dd8ea2f18edcfcdf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1773,6 +1773,19 @@ static struct board_info __initdata boar
+@@ -1774,6 +1774,19 @@ static struct board_info __initdata boar
        },
  
        .has_ohci0 = 1,
index 4a507d09af5a442a1406156fa2339758db2361f7..be615ba25cc6245583732352842a6886e933bc6a 100644 (file)
@@ -36,7 +36,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1480,6 +1488,8 @@ static struct board_info __initdata boar
+@@ -1481,6 +1489,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -45,7 +45,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1659,6 +1669,8 @@ static struct board_info __initdata boar
+@@ -1660,6 +1670,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -54,7 +54,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1735,6 +1747,8 @@ static struct board_info __initdata boar
+@@ -1736,6 +1748,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -63,7 +63,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1758,6 +1772,8 @@ static struct board_info __initdata boar
+@@ -1759,6 +1773,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -72,7 +72,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1779,6 +1795,8 @@ static struct board_info __initdata boar
+@@ -1780,6 +1796,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -81,7 +81,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2124,6 +2142,8 @@ static struct board_info __initdata boar
+@@ -2125,6 +2143,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -90,7 +90,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2178,6 +2198,8 @@ static struct board_info __initdata boar
+@@ -2179,6 +2199,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -99,7 +99,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2320,6 +2342,8 @@ static struct board_info __initdata boar
+@@ -2321,6 +2343,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2439,6 +2463,8 @@ static struct board_info __initdata boar
+@@ -2440,6 +2464,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
index 56466c4e4ebf42cee35d86a3fc6ff7fa70ebaf17..998a4d7bff6d498808c2175b5050caa4e7ab6155 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2471,6 +2471,94 @@ static struct board_info __initdata boar
+@@ -2472,6 +2472,94 @@ static struct board_info __initdata boar
  
        .has_ohci0                      = 1,
        .has_ehci0                      = 1,
index 2d6ecda354a852ab989f3b944069deda75fb45d1..2ae479aca32fec3edd0bc2734275157b014a2b95 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3951,6 +4038,9 @@ static const struct board_info __initcon
+@@ -3952,6 +4039,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 38951ef2920b2bf613efe90b928ad5b28cce5f69..1de5d8fb5f2672c1963bddfdefd11d5039f5bbc2 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4040,6 +4128,7 @@ static const struct board_info __initcon
+@@ -4041,6 +4129,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index 4a8b5e7ac682113aa0e4155f9a0a3b165cf20780..caadafdfcb0285e517a3fffebd236963e261b6a3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4120,6 +4120,75 @@ static struct board_info __initdata boar
+@@ -4121,6 +4121,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4200,6 +4269,9 @@ static const struct board_info __initcon
+@@ -4201,6 +4270,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index caef662963c7bde592332b68ff48773ebbd3b2ee..6335c296f8c261b90f912da9a3fbc7e4f4f8129e 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4240,6 +4286,7 @@ static const struct board_info __initcon
+@@ -4241,6 +4287,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index 35720a3cc032d998bc4e1912d12060f982afed13..505aa3802046fa0af2bad01736e8f8b18cbe8edd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4232,6 +4232,108 @@ static struct board_info __initdata boar
+@@ -4233,6 +4233,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4318,6 +4420,7 @@ static const struct board_info __initcon
+@@ -4319,6 +4421,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index 471e034ff6ca1e31a9bc8d8c9e64a6915075817a..00a472b7f60256bd75ff0210aa1305d94c5f41c9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4169,6 +4169,131 @@ static struct board_info __initdata boar
+@@ -4170,6 +4170,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4419,6 +4544,7 @@ static const struct board_info __initcon
+@@ -4420,6 +4545,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 37bcd0b52b4bdc0d7262743556b774778bc6406e..8401204dd55431430243af1d07ee408bfa48c124 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4163,6 +4164,117 @@ static struct board_info __initdata boar
+@@ -4164,6 +4165,117 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4542,6 +4654,7 @@ static const struct board_info __initcon
+@@ -4543,6 +4655,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 4d5c143442ab88cfecd9ba271b01b51919db7d48..e88c1e142addb778b7f4a40df18553a24b58399d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4165,6 +4165,116 @@ static struct board_info __initdata boar
+@@ -4166,6 +4166,116 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4654,6 +4764,7 @@ static const struct board_info __initcon
+@@ -4655,6 +4765,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index a722c458b752657352f291edb57f47da2a003815..e860bcc48d7a52919003a2893b19270de6f81416 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4275,6 +4275,116 @@ static struct board_info __initdata boar
+@@ -4276,6 +4276,116 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4765,6 +4875,7 @@ static const struct board_info __initcon
+@@ -4766,6 +4876,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 36d20e72f4656316923b45d3f907c35eb0eece51..61300806349be7cf0b008013a46b29c563e48cf0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4174,6 +4174,96 @@ static struct sprom_fixup __initdata vr3
+@@ -4175,6 +4175,96 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .expected_cpu_id                = 0x6368,
-@@ -4874,6 +4964,7 @@ static const struct board_info __initcon
+@@ -4875,6 +4965,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 159e338967b158876256b6a117b57577cfc7953d..f135b4c78e16003ec98c24064a32e23e5d9cd31a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3221,6 +3221,56 @@ static struct board_info __initdata boar
+@@ -3222,6 +3222,56 @@ static struct board_info __initdata boar
        .num_spis = ARRAY_SIZE(ct6373_spi_devices),
  };
  
@@ -57,7 +57,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -4948,6 +4998,7 @@ static const struct board_info __initcon
+@@ -4949,6 +4999,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 904d274093639792f8a4cedb1f33ba36e6776dd6..3b5c8ad073b4efc88f4f48c61903bf58dd0264b9 100644 (file)
@@ -96,7 +96,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -4949,6 +5038,7 @@ static const struct board_info __initcon
+@@ -4950,6 +5039,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 3a7253662fee518926226df11585cd04a6799398..ee4b313fa2b0343ccea1f40fb02a2edd390d746b 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5032,6 +5167,7 @@ static const struct board_info __initcon
+@@ -5033,6 +5168,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 7c9bb274957cf62c19b71d9381cf325c9d9b340a..8b0bbc17906bb61e605afb1d850446ace7ba718c 100644 (file)
@@ -13,3 +13,12 @@ define Profile/CT536_CT5621/Description
   Package set optimized for CT-536+/CT-5621.
 endef
 $(eval $(call Profile,CT536_CT5621))
+
+define Profile/CT5365
+  NAME:=Comtrend CT-5365
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/CT5365/Description
+  Package set optimized for CT-5365.
+endef
+$(eval $(call Profile,CT5365))