package/uboot-envtools: make fw_setenv symlink optional
authorGabor Juhos <juhosg@openwrt.org>
Tue, 1 Nov 2011 09:23:29 +0000 (09:23 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 1 Nov 2011 09:23:29 +0000 (09:23 +0000)
Make the creation of the fw_set-symlink optional, so it can be
disabled in user-builds so only people who know what they are
doing will mess with uboot-env.

Signed-off-by: Daniel Golle <dgolle@allnet.de>
SVN-Revision: 28698

package/uboot-envtools/Makefile

index 19aebc215f5cd3aeda1e0ffc976adddd36e89361..adb2aeabb4851d7d01a05e63fab812ba4d1e2fee 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2011.06
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
@@ -32,10 +32,17 @@ define Package/uboot-envtools/description
  This package includes tools to read and modify U-Boot bootloader environment.
 endef
 
+define Package/uboot-envtools/config
+        config PACKAGE_uboot-envtools_setenv_symlink
+                bool "create fw_setenv symlink"
+endef
+
 define Package/uboot-envtools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/fw_printenv $(1)/usr/sbin/
-       ln -sf fw_printenv $(1)/usr/sbin/fw_setenv
+ifneq ($(CONFIG_PACKAGE_uboot-envtools_setenv_symlink),)
+       ln -s fw_printenv $(1)/usr/sbin/fw_setenv
+endif
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/uboot-envtools.init $(1)/etc/init.d/uboot-envtools
 endef