create Linksys WRTU54G-TM profile
authorFlorian Fainelli <florian@openwrt.org>
Fri, 7 Dec 2012 18:02:31 +0000 (18:02 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 7 Dec 2012 18:02:31 +0000 (18:02 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34572

target/linux/adm8668/Makefile
target/linux/adm8668/profiles/100-WRTU54G-TM.mk [new file with mode: 0644]

index 4e49332b6fab43f96691777f7021b4039b718b98..de3b9e787823dafe91194bbca39bd44e336cfc57 100644 (file)
@@ -15,8 +15,6 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
-# kmod-switch kmod-diag nvram
 
 define Target/Description
        Build firmware images for Infineon WildPass (ADM8668) based routers
diff --git a/target/linux/adm8668/profiles/100-WRTU54G-TM.mk b/target/linux/adm8668/profiles/100-WRTU54G-TM.mk
new file mode 100644 (file)
index 0000000..3ff0307
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRTU54G-TM
+  NAME:=Linksys WRTU54G T-Mobile (Default)
+  PACKAGES:=kmod-rt61-pci kmod-usb2 wpad-mini
+endef
+
+define Profile/WRTU54G-TM/Description
+       Package set compatible with the Linksys WRTU54G T-Mobile
+endef
+$(eval $(call Profile,WRTU54G-TM))
+