avr32: create network config dynamically
authorGabor Juhos <juhosg@openwrt.org>
Tue, 12 Mar 2013 13:28:19 +0000 (13:28 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 12 Mar 2013 13:28:19 +0000 (13:28 +0000)
The default network configuration from base-files
is not correct for the NGW100 board.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35979

target/linux/avr32/base-files.mk [new file with mode: 0644]
target/linux/avr32/base-files/etc/uci-defaults/02_network [new file with mode: 0755]

diff --git a/target/linux/avr32/base-files.mk b/target/linux/avr32/base-files.mk
new file mode 100644 (file)
index 0000000..d6682bd
--- /dev/null
@@ -0,0 +1,5 @@
+define Package/base-files/install-target
+       rm -f $(1)/etc/config/network
+endef
+
+
diff --git a/target/linux/avr32/base-files/etc/uci-defaults/02_network b/target/linux/avr32/base-files/etc/uci-defaults/02_network
new file mode 100755 (executable)
index 0000000..3676146
--- /dev/null
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+
+[ -e /etc/config/network ] && exit 0
+
+touch /etc/config/network
+
+. /lib/functions/uci-defaults.sh
+
+ucidef_set_interface_loopback
+ucidef_set_interfaces_lan_wan "eth1" "eth0"
+
+uci commit network
+
+exit 0